diff mbox series

[bug#55605,1/2] gnu: Add qbe.

Message ID 20220524012155.48729-1-antero@mailbox.org
State Accepted
Headers show
Series [bug#55605,1/2] gnu: Add qbe. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Antero Mejr May 24, 2022, 1:21 a.m. UTC
* gnu/packages/c.scm (qbe): New variable.
---
Hare + QBE builds, tested running a Hello World program using the stdlib.

 gnu/packages/c.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

M May 24, 2022, 4:56 p.m. UTC | #1
Antero Mejr via Guix-patches via schreef op ma 23-05-2022 om 21:21 [-
0400]:
> +      (arguments
> +       `(#:tests? #f ;no test suite
> +         #:make-flags
> +         (list (string-append "CC="
> +                              ,(cc-for-target))
> +               (string-append "DESTDIR="
> +                              (assoc-ref %outputs "out"))
> +               "PREFIX=")

Guix doesn't use this kind of staging, "PREFIX=" (assoc-ref %outputs
"out") should be sufficient, no need for DESTDIR.  And the somewhat
obscure 'assoc-ref' can be eliminated and the strata made more explicit
with gexps:

   (arguments
     (list #:tests? #f ;...
           #:make-flags
           #~(list (string-append "CC=" #$(cc-for-target))
                   (string-append "PREFIX=" #$output))))
M May 24, 2022, 9:06 p.m. UTC | #2
Antero Mejr via Guix-patches via schreef op ma 23-05-2022 om 21:21 [-
0400]:
> * gnu/packages/c.scm (qbe): New variable.

Looks like someone wrote a patch for this previously (+ applied):
<https://issues.guix.gnu.org/53833>.  The 'hare' part hasn't been done
yet though.

For future reference, you can use
https://issues.guix.gnu.org/search?query=qbe
to look if a patch already exists for the package.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index e14e56ad71..01fd2e9a96 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -13,6 +13,7 @@ 
 ;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2021 David Dashyan <mail@davie.li>
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1096,3 +1097,37 @@  (define-public utf8-h
 C and C++.  The functions it provides are like those from the C header
 string.h, but with a utf8* prefix instead of the str* prefix.")
       (license license:unlicense))))
+
+(define-public qbe
+  (let ((commit "9a3e131cf713f8619705f906caf28c5809708ad0") (revision "0"))
+    (package
+      (name "qbe")
+      (version (git-version "0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "git://c9x.me/qbe.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "04dhdm2j84h9hlqj934wh9v456v3kzh0ayxs1gncyh4inv3b41cf"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f ;no test suite
+         #:make-flags
+         (list (string-append "CC="
+                              ,(cc-for-target))
+               (string-append "DESTDIR="
+                              (assoc-ref %outputs "out"))
+               "PREFIX=")
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)))) ;no configure script
+      (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-linux"))
+      (home-page "https://c9x.me/compile/")
+      (synopsis "Compiler backend written in C")
+      (description
+       "QBE aims to be a pure C embeddable backend that provides 70% of the
+performance of advanced compilers in 10% of the code.")
+      (license license:expat))))