diff mbox series

[bug#48702,v6,4/4] gnu: b4: Enable patch attestation.

Message ID 20220522222807.332757-5-kyle@kyleam.com
State Accepted
Headers show
Series Add patatt and enable patch attestation for b4 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Kyle Meyer May 22, 2022, 10:28 p.m. UTC
* gnu/packages/version-control.scm (b4) [propagated-inputs]: Add patatt.
---
 gnu/packages/version-control.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

M May 23, 2022, 9:25 a.m. UTC | #1
Kyle Meyer schreef op zo 22-05-2022 om 18:28 [-0400]:
> +    (propagated-inputs
> +     (list patatt))

Preferably this wouldn't be propagated.  Would adding it to 'inputs'
suffice?

Also, looks like 'git' is missing in the inputs. From b4/__init__.py:

def git_run_command(gitdir: Optional[str], args: List[str], stdin: Optional[bytes] = None,
                    logstderr: bool = False) -> Tuple[int, str]:
    cmdargs = ['git', '--no-pager']


Maybe it needs a 'substitute*' to replace 'git' by the absolute file name
or some wrapping to add the 'git' binary to the $PATH?.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 43ae1eec46..5badc28fc5 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2620,6 +2620,8 @@  (define-public b4
                (delete 'sanity-check))))
     (inputs
      (list python-dkimpy python-dnspython python-requests))
+    (propagated-inputs
+     (list patatt))
     (home-page "https://git.kernel.org/pub/scm/utils/b4/b4.git")
     (synopsis "Tool for working with patches in public-inbox archives")
     (description