diff mbox series

[bug#55558] gnu: emacs-list-utils: update to latest commit

Message ID 20220521100117.7776-1-erik.sab@gmail.com
State Accepted
Headers show
Series [bug#55558] gnu: emacs-list-utils: update to latest commit | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Erik Šabič May 21, 2022, 10:01 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-list-utils): [version] The latest
commit (0dec8c02962d2591766739e37c5714ba21133093) contains both the
patch-require-cl, which I removed, and calls to define-obsolete-function-alias
are made with 3 arguments instead of 2, which is necessary to compile with
Emacs 28.1
---
 gnu/packages/emacs-xyz.scm | 44 ++++++++++++++++----------------------
 1 file changed, 19 insertions(+), 25 deletions(-)


base-commit: 94b28247d1b976e9c01c75794663603b7b81eaeb

Comments

Tobias Geerinckx-Rice May 26, 2022, 7:49 p.m. UTC | #1
Erik,

Thank you!

This build failure was bugging a lot of people, so I pushed your 
fix as commit c5d68c6d12e691bceba60bc9537ea499bb50273d, with a 
message matching out conventions.
Please take a look.

For example, we use a specific ‘gnu: foo: Update to $VERSION.’ 
title, and again in the changelog section.

Erik Šabič 写道:
> * gnu/packages/emacs-xyz.scm (emacs-list-utils): [version] The 
> latest
> commit (0dec8c02962d2591766739e37c5714ba21133093) contains both 
> the
> patch-require-cl, which I removed, and calls to 
> define-obsolete-function-alias
> are made with 3 arguments instead of 2, which is necessary to 
> compile with
> Emacs 28.1

I moved this comment to the code.  Comments like this almost 
*never* belong in commit messages.  Who reads those — in context — 
after a week?

Thanks again!

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ae81f4e395..944597139a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18730,31 +18730,25 @@  (define-public emacs-helm-gtags
     (license license:gpl3+)))
 
 (define-public emacs-list-utils
-  (package
-    (name "emacs-list-utils")
-    (version "0.4.6")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/rolandwalker/list-utils")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "07hbz2md52ccy95gv4d5n6szrfmpfqf3w4kwqdg2cf54c7kgf7hw"))))
-    (build-system emacs-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-require-cl
-           (lambda _
-             (substitute* "list-utils.el"
-               (("\\(require 'cl\\)") "(require 'cl-lib)"))
-             #t)))))
-    (home-page "https://github.com/rolandwalker/list-utils")
-    (synopsis "List-manipulation utility functions")
-    (description "This package provides a list manipulation library for Emacs.")
-    (license license:gpl3+)))
+  (let ((commit "0dec8c02962d2591766739e37c5714ba21133093") (revision "1"))
+    (package
+      (name "emacs-list-utils")
+      (version (git-version "0.4.6" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/rolandwalker/list-utils")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "11nm8649a131bn2kwj4fxkiijdx2d4f1byx7a985zlb3bzdwnaw8"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/rolandwalker/list-utils")
+      (synopsis "List-manipulation utility functions")
+      (description
+       "This package provides a list manipulation library for Emacs.")
+      (license license:gpl3+))))
 
 (define-public emacs-parsec
   (package