diff mbox series

[bug#55524] gnu: Add emacs-terminal-here.

Message ID 20220519152730.13290-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#55524] gnu: Add emacs-terminal-here. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart May 19, 2022, 3:27 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-terminal-here): New variable.
---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Liliana Marie Prikler May 19, 2022, 7:27 p.m. UTC | #1
Am Donnerstag, dem 19.05.2022 um 10:27 -0500 schrieb jgart:
> * gnu/packages/emacs-xyz.scm (emacs-terminal-here): New variable.
Pushed with slightly adapted synopsis and description.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index de8698990a..92c4865b75 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -485,6 +485,27 @@  (define-public emacs-vc-hgcmd
 server}.  The main advantage compared to @code{vc-hg} is speed.")
     (license license:gpl3+)))
 
+(define-public emacs-terminal-here
+  (package
+    (name "emacs-terminal-here")
+    (version "2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/davidshepherd7/terminal-here")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1iv1c2mbvhn00ha46c6f98j9syc71xhjpk8m5wa5p32sk4wcc9f4"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/davidshepherd7/terminal-here")
+    (synopsis "Opens an external terminal in Emacs")
+    (description
+"@code{emacs-terminal-here} opens an external terminal emulator in
+directories associated with the current buffer.")
+    (license license:gpl3+)))
+
 (define-public emacs-hgignore-mode
   ;; From 2021-03-14.
   ;; No releases available.