diff mbox series

[bug#55508] gnu: python-geopandas: Fix build.

Message ID 20220518192111.20342-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#55508] gnu: python-geopandas: Fix build. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber May 18, 2022, 7:21 p.m. UTC
* gnu/packages/geo.scm (python-geopandas)[arguments]: Disable broken
  tests. Re-enable test_fillna_no_op_returns_copy which does not fail
  anymore.
---
 gnu/packages/geo.scm | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)

Comments

Ludovic Courtès May 20, 2022, 10:14 p.m. UTC | #1
Hi,

Felix Gruber <felgru@posteo.net> skribis:

> * gnu/packages/geo.scm (python-geopandas)[arguments]: Disable broken
>   tests. Re-enable test_fillna_no_op_returns_copy which does not fail
>   anymore.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c2569c27d4..0c9240eea7 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -715,9 +715,14 @@  pyproj, Rtree, and Shapely.")
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
                (invoke "pytest"
-                       ; Disable test that fails with
-                       ; NotImplementedError in pandas.
-                       "-k" "not test_fillna_no_op_returns_copy"
+                       ; Disable tests that fail due to incompatibilities
+                       ; with our pandas version.
+                       "-k"
+                       (string-append
+                         "not test_getitem_invalid"
+                         " and not test_value_counts"
+                         " and not test_setitem_invalid"
+                         " and not test_insert_invalid")
                        ; Disable tests that require internet access.
                        "-m" "not web")))))))
     (propagated-inputs