diff mbox series

[bug#55485,v2] gnu: wla-dx: Update to 10.1.

Message ID 20220518173118.17979-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#55485,v2] gnu: wla-dx: Update to 10.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber May 18, 2022, 5:31 p.m. UTC
* gnu/packages/assembly.scm (wla-dx): Update to 10.1.
[native-inputs]: Use new style.
[arguments]: Add custom 'check phase to run run_tests.sh.
---
 gnu/packages/assembly.scm | 19 ++++++++++++++-----
 1 file changed, 14 insertions(+), 5 deletions(-)

Comments

Ludovic Courtès May 29, 2022, 9:35 p.m. UTC | #1
Hi,

Felix Gruber <felgru@posteo.net> skribis:

> * gnu/packages/assembly.scm (wla-dx): Update to 10.1.
> [native-inputs]: Use new style.
> [arguments]: Add custom 'check phase to run run_tests.sh.

Applied, thank you & thanks Maxime!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index b2830716e1..ca50b00a06 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -342,7 +343,7 @@  package for the Game Boy and Game Boy Color.  It consists of:
 (define-public wla-dx
   (package
     (name "wla-dx")
-    (version "9.12")
+    (version "10.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -351,12 +352,20 @@  package for the Game Boy and Game Boy Color.  It consists of:
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1wlbqv2rgk9q6m9an1mi0i29250zl8lw7zipki2bbi9mczpyczli"))))
+                "1nh2k2xn5fj389gq68f3fxgrxakgn8c6dw2ffqay86s3706hac9w"))))
     (build-system cmake-build-system)
-    (native-inputs
-     `(("sphinx" ,python-sphinx)))      ; to generate man pages
+    (native-inputs (list python-sphinx)) ; to generate man pages
     (arguments
-     `(#:tests? #f))                    ; no tests
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'copy-tests-to-build-directory
+           (lambda _
+             (copy-recursively "../source/tests" "tests")))
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (let ((sh (which "sh")))
+               (when tests?
+                 (invoke sh "../source/run_tests.sh"))))))))
     (home-page "https://github.com/vhelin/wla-dx")
     (synopsis "Assemblers for various processors")
     (description "WLA DX is a set of tools to assemble assembly files to