diff mbox series

[bug#55502,1/3] gnu: Add python-climin.

Message ID 20220518162004.1536-1-wzelazny@vurv.cz
State Accepted
Headers show
Series [bug#55502,1/3] gnu: Add python-climin. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Zelazny May 18, 2022, 4:20 p.m. UTC
* gnu/packages/python-science.scm (python-climin): New variable.
---
 gnu/packages/python-science.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

-- 
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index bf7c7ce45f..ad17401a61 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
 ;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2022 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1222,3 +1223,25 @@  (define-public python-traittypes
 out of the scope of the main traitlets project but are a common requirement to
 build applications with traitlets in combination with the scipy stack.")
     (license license:bsd-3)))
+
+(define-public python-climin
+  (package
+    (name "python-climin")
+    (version "0.1a1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "climin" version))
+              (sha256
+               (base32
+                "1wpjisd5zzi5yvjff02hnxn84822k8sdxvvd33lil2x79wdb36rv"))))
+    (build-system python-build-system)
+    (native-inputs (list python-nose))
+    (propagated-inputs (list python-numpydoc python-numpy python-scipy))
+    (home-page "https://github.com/BRML/climin")
+    (synopsis "Optimization for machine learning")
+    (description
+     "@command{climin} is a Python package for optimization,
+heavily biased to machine learning scenarios distributed under the BSD 3-clause
+license.  It works on top of @command{numpy} and (partially)
+@command{gnumpy}.")
+    (license license:bsd-3)))