diff mbox series

[bug#53777,v2] gnu: Add python-posix-ipc

Message ID 20220515033053.13824-1-ian@eonn.xyz
State New
Headers show
Series [bug#53777,v2] gnu: Add python-posix-ipc | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ian Ressa May 15, 2022, 3:30 a.m. UTC
Sorry, I really dropped the ball on this one.
This patch is against a newer python-xyz.scm and fixes the issues listed.

---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 020f078dee..d6486291d3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -121,6 +121,7 @@ 
 ;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
 ;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Ian Ressa <ian@eonn.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31150,3 +31151,28 @@  (define-public python-deepmerge
      "The @code{deep-merge} Python library provides a toolset to deeply merge
 nested data structures in Python like lists and dictionaries.")
     (license license:expat)))
+
+(define-public python-posix-ipc
+  (package
+    (name "python-posix-ipc")
+    (version "1.0.5")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "posix_ipc" version))
+              (sha256
+	       (base32 "15wbxf67y17g04i3f3vjw9zjbvlvqqk9q1x0ya1y7apl5k7b3pbc"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'support-cross-compilation
+           (lambda _
+             (substitute* "prober.py"
+               (("cc") ,(cc-for-target))))))))
+  (home-page "https://semanchuk.com/philip/posix_ipc/")
+  (synopsis "POSIX IPC primitives for Python")
+  (description
+   "The Python extension module posix_ipc gives Python access to POSIX
+inter-process semaphores, shared memory and message queues on systems that
+support the POSIX Realtime Extensions a.k.a. POSIX 1003.1b-1993.")
+  (license license:bsd-3)))