diff mbox series

[bug#55418] gnu: emacs-dash: Fix build with emacs28.

Message ID 20220514213957.21292-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#55418] gnu: emacs-dash: Fix build with emacs28. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder May 14, 2022, 9:39 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-dash)[phase]:
Add phase 'disable-byte-compile-error-on-warn.
---
 gnu/packages/emacs-xyz.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

Comments

Liliana Marie Prikler May 14, 2022, 11:38 p.m. UTC | #1
Am Samstag, dem 14.05.2022 um 23:39 +0200 schrieb Michael Rohleder:
> * gnu/packages/emacs-xyz.scm (emacs-dash)[phase]:
> Add phase 'disable-byte-compile-error-on-warn.
> ---
Applied with a small fix in the commit message.

Thanks
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c18505a681..928ca1c120 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3677,7 +3677,14 @@  (define-public emacs-dash
                (base32
                 "0z6f8y1m9amhg427iz1d4xcyr6n0kj5w7kmiz134p320ixsdnzd8"))))
     (build-system emacs-build-system)
-    (arguments `(#:tests? #t))
+    (arguments `(#:tests? #t
+                 #:phases
+                 (modify-phases %standard-phases
+                   (add-after 'unpack 'disable-byte-compile-error-on-warn
+                     (lambda _
+                       (substitute* "Makefile"
+                         (("\\(setq byte-compile-error-on-warn t\\)")
+                          "(setq byte-compile-error-on-warn nil)")))))))
     (home-page "https://github.com/magnars/dash.el")
     (synopsis "Modern list library for Emacs")
     (description "This package provides a modern list API library for Emacs.")