diff mbox series

[bug#53834,v2] gnu: Add cproc.

Message ID 20220508202500.10449-1-paren@disroot.org
State Accepted
Headers show
Series [bug#53834,v2] gnu: Add cproc. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

\( May 8, 2022, 8:25 p.m. UTC
* gnu/packages/c.scm (cproc): New variable.

Signed-off-by: (unmatched-parenthesis <paren@disroot.org>
---
This improved patch fixes some style nits.

Thanks to lilyp for pointing them out on #guix!

 gnu/packages/c.scm | 46 ++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)

Comments

Maxim Cournoyer July 7, 2022, 8:12 p.m. UTC | #1
Hello!

"(unmatched-parenthesis" <paren@disroot.org> writes:

> * gnu/packages/c.scm (cproc): New variable.
>
> Signed-off-by: (unmatched-parenthesis <paren@disroot.org>
> ---
> This improved patch fixes some style nits.
>
> Thanks to lilyp for pointing them out on #guix!
>
>  gnu/packages/c.scm | 46 ++++++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 46 insertions(+)
>
> diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
> index c9a25eb801..216ddfef88 100644
> --- a/gnu/packages/c.scm
> +++ b/gnu/packages/c.scm
> @@ -47,6 +47,7 @@ (define-module (gnu packages c)
>    #:use-module (gnu packages bison)
>    #:use-module (gnu packages check)
>    #:use-module (gnu packages flex)
> +  #:use-module (gnu packages gcc)
>    #:use-module (gnu packages perl)
>    #:use-module (gnu packages texinfo)
>    #:use-module (gnu packages guile)
> @@ -1108,3 +1109,48 @@ (define-public qbe
>  language as input.")
>      (home-page "https://c9x.me/compile/")
>      (license license:expat))))
> +
> +(define-public cproc
> +  (let ((commit "70fe9ef1810cc6c05bde9eb0970363c35fa7e802")
> +        (revision "1"))
> +    (package
> +     (name "cproc")
> +     (version (git-version "0.0" revision commit))
> +     (source
> +      (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://git.sr.ht/~mcf/cproc")
> +             (commit commit)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "1qmgzll7z7mn587azkj4cizyyd8ii6iznfxpc66ja08140sbn9yx"))))
> +     (build-system gnu-build-system)
> +     (arguments
> +      (list #:make-flags
> +            #~(list (string-append "CC=" #$(cc-for-target))
> +                    (string-append "PREFIX=" #$output))
> +            #:phases
> +            #~(modify-phases %standard-phases
> +                (replace 'configure
> +                  (lambda* (#:key inputs outputs #:allow-other-keys)
> +                    (let ((out (assoc-ref outputs "out"))
> +                          (gcc-lib (assoc-ref inputs "gcc:lib"))
> +                          (host-system #$(nix-system->gnu-triplet (%current-system)))
> +                          (target-system
> +                           #$(nix-system->gnu-triplet (or (%current-target-system)
> +                                                          (%current-system)))))
> +                      (invoke "./configure"
> +                              (string-append "--prefix=" out)
> +                              (string-append "--host=" host-system)
> +                              (string-append "--target=" target-system)
> +                              (string-append "--with-ld=" #$(ld-for-target))
> +                              (string-append "--with-gcc-libdir=" gcc-lib))))))))
> +     (inputs `(("qbe" ,qbe)
> +               ("gcc:lib" ,gcc "lib")))
> +     (supported-systems (list "x86_64-linux" "aarch64-linux"))
> +     (synopsis "Simple C11 compiler backed by QBE")
> +     (description "@code{cproc} is a C compiler using QBE as a backend, supporting most of C11
> +along with some GCC and C2x extensions.")
> +     (home-page "https://sr.ht/~mcf/cproc")
> +     (license license:expat))))

Well done!  I've adjusted slightly the source to fit under 80 columns,
and push as 96eb2337b5c3d43c99979222633987a8e45df4b9.  Thank you!

Maxim
\( July 8, 2022, 6:40 a.m. UTC | #2
On Thu Jul 7, 2022 at 9:12 PM BST, Maxim Cournoyer wrote:
> Well done!  I've adjusted slightly the source to fit under 80 columns,
> and push as 96eb2337b5c3d43c99979222633987a8e45df4b9.  Thank you!

Thanks Maxim! :)

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index c9a25eb801..216ddfef88 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -47,6 +47,7 @@  (define-module (gnu packages c)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages check)
   #:use-module (gnu packages flex)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages guile)
@@ -1108,3 +1109,48 @@  (define-public qbe
 language as input.")
     (home-page "https://c9x.me/compile/")
     (license license:expat))))
+
+(define-public cproc
+  (let ((commit "70fe9ef1810cc6c05bde9eb0970363c35fa7e802")
+        (revision "1"))
+    (package
+     (name "cproc")
+     (version (git-version "0.0" revision commit))
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~mcf/cproc")
+             (commit commit)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1qmgzll7z7mn587azkj4cizyyd8ii6iznfxpc66ja08140sbn9yx"))))
+     (build-system gnu-build-system)
+     (arguments
+      (list #:make-flags
+            #~(list (string-append "CC=" #$(cc-for-target))
+                    (string-append "PREFIX=" #$output))
+            #:phases
+            #~(modify-phases %standard-phases
+                (replace 'configure
+                  (lambda* (#:key inputs outputs #:allow-other-keys)
+                    (let ((out (assoc-ref outputs "out"))
+                          (gcc-lib (assoc-ref inputs "gcc:lib"))
+                          (host-system #$(nix-system->gnu-triplet (%current-system)))
+                          (target-system
+                           #$(nix-system->gnu-triplet (or (%current-target-system)
+                                                          (%current-system)))))
+                      (invoke "./configure"
+                              (string-append "--prefix=" out)
+                              (string-append "--host=" host-system)
+                              (string-append "--target=" target-system)
+                              (string-append "--with-ld=" #$(ld-for-target))
+                              (string-append "--with-gcc-libdir=" gcc-lib))))))))
+     (inputs `(("qbe" ,qbe)
+               ("gcc:lib" ,gcc "lib")))
+     (supported-systems (list "x86_64-linux" "aarch64-linux"))
+     (synopsis "Simple C11 compiler backed by QBE")
+     (description "@code{cproc} is a C compiler using QBE as a backend, supporting most of C11
+along with some GCC and C2x extensions.")
+     (home-page "https://sr.ht/~mcf/cproc")
+     (license license:expat))))