diff mbox series

[bug#55276,v2] gnu: Add xkblayout.

Message ID 20220506062254.8926-1-attila@lendvai.name
State Accepted
Headers show
Series [bug#55276,v2] gnu: Add xkblayout. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Attila Lendvai May 6, 2022, 6:22 a.m. UTC
* gnu/packages/xdisorg.scm (xkblayout): New variable.
---

i've addressed the issues i could, but i'm not sure anymore
whether this should be packaged for Guix at all. maybe
people should just clone the repo and run it from there?

feel free to reject it.

either way, i've requested some clarifications:

https://gitlab.freedesktop.org/whot/xkblayout/-/issues/

licensing is contradictory, COPYING says GPL.

 gnu/packages/xdisorg.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

M May 6, 2022, 12:19 p.m. UTC | #1
Attila Lendvai schreef op vr 06-05-2022 om 08:22 [+0200]:
> +  ;; Upstream doesn't have any version numbers
> +  (let ((version "0.0.0")
> +        (revision "0")
> +        (commit "c0851b0f4bc9bc1a07240605baac8e50abe63fa8"))

TBC I don't think this is a blocker, it's more of an ‘it would be
convenient to have them’ thing.

Greetings,
Maxime.
M May 6, 2022, 12:21 p.m. UTC | #2
Attila Lendvai schreef op vr 06-05-2022 om 08:22 [+0200]:
> * gnu/packages/xdisorg.scm (xkblayout): New variable.
> ---
> 
> i've addressed the issues i could, but i'm not sure anymore
> whether this should be packaged for Guix at all.

I don't see why not, it's software and Guix is a software distribution
and some people create their own layouts.  Though you can close the
debbugs issue if you want to.

Greetings,
Maxime.
Ludovic Courtès May 9, 2022, 10:06 a.m. UTC | #3
Hi,

Attila Lendvai <attila@lendvai.name> skribis:

> * gnu/packages/xdisorg.scm (xkblayout): New variable.

Applied, thanks!  And thanks to Maxime for reviewing.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d41c520962..08f4780fc2 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -387,6 +387,30 @@  (define-public xkb-switch
 state.")
     (license license:gpl3+)))
 
+(define-public xkblayout
+  ;; Upstream doesn't have any version numbers
+  (let ((version "0.0.0")
+        (revision "0")
+        (commit "c0851b0f4bc9bc1a07240605baac8e50abe63fa8"))
+    (package
+      (name "xkblayout")
+      (version (git-version version revision commit))
+      (home-page "https://gitlab.freedesktop.org/whot/xkblayout")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url home-page)
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0057988l5l7pmwg7dp6cqvj5l4lr0g5z3wq189g6kz36l9rmh675"))))
+      (build-system python-build-system)
+      (synopsis "XKB layout template generator")
+      (description "xkblayout is a CLI application to generate templates for
+a new XKB layout, either in the user's home directory or the system directory.")
+      (license license:gpl3+))))
+
 (define-public xclip
   (package
     (name "xclip")