diff mbox series

[bug#55276] gnu: Add xkblayout.

Message ID 20220505164658.4654-1-attila@lendvai.name
State Accepted
Headers show
Series [bug#55276] gnu: Add xkblayout. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Attila Lendvai May 5, 2022, 4:46 p.m. UTC
* gnu/packages/xdisorg.scm (xkblayout): New variable.
---
 gnu/packages/xdisorg.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

M May 5, 2022, 5:18 p.m. UTC | #1
Attila Lendvai schreef op do 05-05-2022 om 18:46 [+0200]:
> +(define-public xkblayout
> +  ;; Upstream has no tags as of 2022-05-04
> +  (let ((revision "0")
> +        (commit "c0851b0f4bc9bc1a07240605baac8e50abe63fa8"))

I don't think the lack of tags matters, what relevant is whether there
is some kind of version number system.  So I'd go for

  ;; Upstream doesn't have any version numbers

However, upstream does have versions:

https://gitlab.freedesktop.org/whot/xkblayout/-/blob/master/setup.py#L6

... but it's an old version, so maybe upstream could be asked if it's a
’good’ version?

Greetings,
Maxime.
M May 5, 2022, 5:19 p.m. UTC | #2
Attila Lendvai schreef op do 05-05-2022 om 18:46 [+0200]:
> +      (version (string-append "0.0.0-" revision "-" (substring commit 0 7)))

'git-version'?
M May 5, 2022, 5:19 p.m. UTC | #3
Attila Lendvai schreef op do 05-05-2022 om 18:46 [+0200]:
> +      (license license:gpl3+))))

xkblayout.py says otherwise (some kind of BSD maybe?)

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d41c520962..b88f1b9445 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -387,6 +387,29 @@  (define-public xkb-switch
 state.")
     (license license:gpl3+)))
 
+(define-public xkblayout
+  ;; Upstream has no tags as of 2022-05-04
+  (let ((revision "0")
+        (commit "c0851b0f4bc9bc1a07240605baac8e50abe63fa8"))
+    (package
+      (name "xkblayout")
+      (version (string-append "0.0.0-" revision "-" (substring commit 0 7)))
+      (home-page "https://gitlab.freedesktop.org/whot/xkblayout")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url home-page)
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0057988l5l7pmwg7dp6cqvj5l4lr0g5z3wq189g6kz36l9rmh675"))))
+      (build-system python-build-system)
+      (synopsis "XKB layout template generator")
+      (description "xkblayout is a CLI application to generate templates for
+a new XKB layout, either in the user's home directory or the system directory.")
+      (license license:gpl3+))))
+
 (define-public xclip
   (package
     (name "xclip")