diff mbox series

[bug#55255] gnu: openjdk: Update to 11.0.15.

Message ID 20220504063901.15818-1-dannym@scratchpost.org
State Accepted
Headers show
Series [bug#55255] gnu: openjdk: Update to 11.0.15. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Danny Milosavljevic May 4, 2022, 6:39 a.m. UTC
* gnu/packages/java (openjdk): Update to 11.0.15.
[arguments]<#:phases>[fix-java-shebangs]: Adapt phase.
---
 gnu/packages/java.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Ludovic Courtès May 8, 2022, 9:38 p.m. UTC | #1
Hi Danny,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

> * gnu/packages/java (openjdk): Update to 11.0.15.
> [arguments]<#:phases>[fix-java-shebangs]: Adapt phase.

If it works and dependents are fine (which I expect should be the case
for a point release), go for it!

Ludo’.
Danny Milosavljevic May 9, 2022, 10:41 a.m. UTC | #2
Pushed openjdk11 update to guix master as commit 271b2e43bef96f17f3f1e1085394b4bb144c5768.
Greg Hogan May 9, 2022, 5:50 p.m. UTC | #3
On Sun, May 8, 2022 at 5:39 PM Ludovic Courtès <ludo@gnu.org> wrote:

> > * gnu/packages/java (openjdk): Update to 11.0.15.
> > [arguments]<#:phases>[fix-java-shebangs]: Adapt phase.
>
> If it works and dependents are fine (which I expect should be the case
> for a point release), go for it!
>

This evaluation broke openjdk12+:
  https://ci.guix.gnu.org/build/760901/details

Greg
Efraim Flashner May 10, 2022, 12:54 p.m. UTC | #4
On Mon, May 09, 2022 at 01:50:34PM -0400, Greg Hogan wrote:
> On Sun, May 8, 2022 at 5:39 PM Ludovic Courtès <ludo@gnu.org> wrote:
> 
> > > * gnu/packages/java (openjdk): Update to 11.0.15.
> > > [arguments]<#:phases>[fix-java-shebangs]: Adapt phase.
> >
> > If it works and dependents are fine (which I expect should be the case
> > for a point release), go for it!
> >
> 
> This evaluation broke openjdk12+:
>   https://ci.guix.gnu.org/build/760901/details

It's fixed now
diff mbox series

Patch

diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 43422f383f..a644370821 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1768,7 +1768,7 @@  (define-public openjdk11
 (define-public openjdk11
   (package
     (name "openjdk")
-    (version "11.0.13")
+    (version "11.0.15")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://openjdk-sources.osci.io/openjdk11/openjdk-"
@@ -1776,7 +1776,7 @@  (define-public openjdk11
               (file-name (string-append name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "0xavz7msaadprq65p5bhp6sxcyp12p0zlbhb3aaz0cvp21c9pdm9"))
+                "0di91nnms2iq1svgq72r5y17am17r4vh2lq43k0bkcwpc84d6nd8"))
               (modules '((guix build utils)))
               (snippet
                `(begin
@@ -1819,8 +1819,8 @@  (define-public openjdk11
            (lambda _
              ;; This file was "fixed" by patch-source-shebangs, but it requires
              ;; this exact first line.
-             (substitute* "make/data/blacklistedcertsconverter/blacklisted.certs.pem"
-               (("^#!.*") "#! java BlacklistedCertsConverter SHA-256\n"))
+             (substitute* "make/data/blockedcertsconverter/blocked.certs.pem"
+               (("^#!.*") "#! java BlockedCertsConverter SHA-256\n"))
              #t))
          (add-after 'unpack 'patch-jni-libs
            ;; Hardcode dynamically loaded libraries.