[bug#55255] gnu: openjdk: Update to 11.0.15.
Commit Message
* gnu/packages/java (openjdk): Update to 11.0.15.
[arguments]<#:phases>[fix-java-shebangs]: Adapt phase.
---
gnu/packages/java.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
Comments
Hi Danny,
Danny Milosavljevic <dannym@scratchpost.org> skribis:
> * gnu/packages/java (openjdk): Update to 11.0.15.
> [arguments]<#:phases>[fix-java-shebangs]: Adapt phase.
If it works and dependents are fine (which I expect should be the case
for a point release), go for it!
Ludo’.
Pushed openjdk11 update to guix master as commit 271b2e43bef96f17f3f1e1085394b4bb144c5768.
On Sun, May 8, 2022 at 5:39 PM Ludovic Courtès <ludo@gnu.org> wrote:
> > * gnu/packages/java (openjdk): Update to 11.0.15.
> > [arguments]<#:phases>[fix-java-shebangs]: Adapt phase.
>
> If it works and dependents are fine (which I expect should be the case
> for a point release), go for it!
>
This evaluation broke openjdk12+:
https://ci.guix.gnu.org/build/760901/details
Greg
On Mon, May 09, 2022 at 01:50:34PM -0400, Greg Hogan wrote:
> On Sun, May 8, 2022 at 5:39 PM Ludovic Courtès <ludo@gnu.org> wrote:
>
> > > * gnu/packages/java (openjdk): Update to 11.0.15.
> > > [arguments]<#:phases>[fix-java-shebangs]: Adapt phase.
> >
> > If it works and dependents are fine (which I expect should be the case
> > for a point release), go for it!
> >
>
> This evaluation broke openjdk12+:
> https://ci.guix.gnu.org/build/760901/details
It's fixed now
@@ -1768,7 +1768,7 @@ (define-public openjdk11
(define-public openjdk11
(package
(name "openjdk")
- (version "11.0.13")
+ (version "11.0.15")
(source (origin
(method url-fetch)
(uri (string-append "https://openjdk-sources.osci.io/openjdk11/openjdk-"
@@ -1776,7 +1776,7 @@ (define-public openjdk11
(file-name (string-append name "-" version ".tar.bz2"))
(sha256
(base32
- "0xavz7msaadprq65p5bhp6sxcyp12p0zlbhb3aaz0cvp21c9pdm9"))
+ "0di91nnms2iq1svgq72r5y17am17r4vh2lq43k0bkcwpc84d6nd8"))
(modules '((guix build utils)))
(snippet
`(begin
@@ -1819,8 +1819,8 @@ (define-public openjdk11
(lambda _
;; This file was "fixed" by patch-source-shebangs, but it requires
;; this exact first line.
- (substitute* "make/data/blacklistedcertsconverter/blacklisted.certs.pem"
- (("^#!.*") "#! java BlacklistedCertsConverter SHA-256\n"))
+ (substitute* "make/data/blockedcertsconverter/blocked.certs.pem"
+ (("^#!.*") "#! java BlockedCertsConverter SHA-256\n"))
#t))
(add-after 'unpack 'patch-jni-libs
;; Hardcode dynamically loaded libraries.