diff mbox series

[bug#55233,3/3] gnu: Add python-madbg.

Message ID 20220502220026.13800-3-jgart@dismail.de
State New
Headers show
Series Add python-madbg. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart May 2, 2022, 10 p.m. UTC
* gnu/packages/python-xyz.scm (python-madbg): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Maxim Cournoyer June 24, 2022, 3:25 p.m. UTC | #1
jgart <jgart@dismail.de> writes:

> * gnu/packages/python-xyz.scm (python-madbg): New variable.
> ---
>  gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
>  1 file changed, 20 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 61c36699c7..551544b08e 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -29022,6 +29022,26 @@ (define-public python-hypno
>  running python process.")
>      (license license:expat)))
>  
> +(define-public python-madbg
> +  (package
> +    (name "python-madbg")
> +    (version "1.2.0")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (pypi-uri "madbg" version ".zip"))
> +        (sha256
> +          (base32 "19cll917w3zshxrcf2v5bdwkvbam3nslyik2hp4wpn5z4xkzsw5v"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +      (list python-click python-hypno python-ipython python-prompt-toolkit))
> +    (native-inputs (list unzip))
> +    (home-page "https://github.com/kmaork/madbg")
> +    (synopsis "A fully-featured remote debugger for python")
> +    (description
> +      "This package provides a fully-featured remote debugger for python")
> +    (license license:expat)))

Synopsis shouldn't start with determinant (run 'guix lint' to find out).
Description should end with period.  I'd also capitalize "Python", since
it's a proper name.

Make sure the test suite is run [0].

Thanks!

[0]  https://github.com/kmaork/madbg/tree/master/tests
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 61c36699c7..551544b08e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29022,6 +29022,26 @@  (define-public python-hypno
 running python process.")
     (license license:expat)))
 
+(define-public python-madbg
+  (package
+    (name "python-madbg")
+    (version "1.2.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "madbg" version ".zip"))
+        (sha256
+          (base32 "19cll917w3zshxrcf2v5bdwkvbam3nslyik2hp4wpn5z4xkzsw5v"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      (list python-click python-hypno python-ipython python-prompt-toolkit))
+    (native-inputs (list unzip))
+    (home-page "https://github.com/kmaork/madbg")
+    (synopsis "A fully-featured remote debugger for python")
+    (description
+      "This package provides a fully-featured remote debugger for python")
+    (license license:expat)))
+
 (define-public python-iwlib
   (package
     (name "python-iwlib")