diff mbox series

[bug#55229,1/2] gnu: lua-luv: upgrade to version 1.43.0

Message ID 20220502191338.5032-1-ryan@arctype.co
State Accepted
Headers show
Series [bug#55229,1/2] gnu: lua-luv: upgrade to version 1.43.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ryan Sundberg May 2, 2022, 7:13 p.m. UTC
* gnu/packages/lua.scm (lua-luv, lua5.1-luv, lua5.2-luv): Upgrade to 1.43.0
---
 gnu/packages/lua.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index ee4b7727e0..1061977f3b 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -785,7 +785,7 @@  (define-public lua5.2-lpeg
 (define (make-lua-luv name lua)
   (package
     (name name)
-    (version "1.32.0-0")
+    (version "1.43.0-0")
     (source (origin
               ;; The release tarball includes the sources of libuv but does
               ;; not include the pkg-config files.
@@ -796,7 +796,7 @@  (define (make-lua-luv name lua)
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0c65c1lhbl0axnyks3910gjs0z0hw7w6jvl07g8kbpnbvfl4qajh"))))
+                "1yzi4bm845vl84wyv2qw4z1n1v285lgwm681swmp84brfy2s7czp"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f                      ; there are none
@@ -811,9 +811,9 @@  (define (make-lua-luv name lua)
          (add-after 'unpack 'copy-lua-compat
            (lambda* (#:key inputs #:allow-other-keys)
              (copy-recursively (assoc-ref inputs "lua-compat")
-                               "lua-compat")
+                               "deps/lua-compat-5.3")
              (setenv "CPATH"
-                     (string-append (getcwd) "/lua-compat:"
+                     (string-append (getcwd) "/deps/lua-compat-5.3:"
                                     (or (getenv "CPATH") "")))
              #t)))))
     (inputs
@@ -824,11 +824,11 @@  (define (make-lua-luv name lua)
            (method git-fetch)
            (uri (git-reference
                  (url "https://github.com/keplerproject/lua-compat-5.3")
-                 (commit "daebe77a2f498817713df37f0bb316db1d82222f")))
+                 (commit "v0.10")))
            (file-name "lua-compat-5.3-checkout")
            (sha256
             (base32
-             "02a14nvn7aggg1yikj9h3dcf8aqjbxlws1bfvqbpfxv9d5phnrpz"))))))
+             "1caxn228gx48g6kymp9w7kczgxcg0v0cd5ixsx8viybzkd60dcn4"))))))
     (home-page "https://github.com/luvit/luv/")
     (synopsis "Libuv bindings for Lua")
     (description