diff mbox series

[bug#50080,v3,3/4] gnu: sundials-openmpi: Add HYPRE dependency.

Message ID 20220502132806.614632-4-paul@apatience.com
State Accepted
Headers show
Series gnu: sundials: Fix various issues and update to 6.2.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience May 2, 2022, 1:28 p.m. UTC
* gnu/packages/maths.scm (sundials-openmpi)[propagated-inputs]: Add
hypre-openmpi.
[arguments]<#:configure-flags>: Add -DENABLE_HYPRE, -DHYPRE_INCLUDE_DIR
and -DHYPRE_LIBRARY_DIR.
---
 gnu/packages/maths.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5d4778da83..03c465dfff 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6175,12 +6175,19 @@  (define-public sundials-openmpi
     (propagated-inputs
      (list openmpi
            ;; Support for the below requires MPI.
-           ;; TODO: Add HYPRE.
+           hypre-openmpi
            petsc-openmpi))
     (arguments
      (substitute-keyword-arguments (package-arguments sundials)
        ((#:configure-flags flags '())
         `(cons* "-DENABLE_MPI:BOOL=ON"
+                "-DENABLE_HYPRE:BOOL=ON"
+                (string-append "-DHYPRE_INCLUDE_DIR="
+                               (assoc-ref %build-inputs "hypre-openmpi")
+                               "/include")
+                (string-append "-DHYPRE_LIBRARY_DIR="
+                               (assoc-ref %build-inputs "hypre-openmpi")
+                               "/lib")
                 "-DENABLE_PETSC:BOOL=ON"
                 (string-append "-DPETSC_DIR="
                                (assoc-ref %build-inputs "petsc-openmpi"))