diff mbox series

[bug#55215] gnu: emacs-circe: Update to 2.12.

Message ID 20220502023126.22534-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#55215] gnu: emacs-circe: Update to 2.12. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart May 2, 2022, 2:31 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-circe): Update to 2.12.
---
 gnu/packages/emacs-xyz.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Ludovic Courtès May 6, 2022, 8:23 a.m. UTC | #1
jgart <jgart@dismail.de> skribis:

> * gnu/packages/emacs-xyz.scm (emacs-circe): Update to 2.12.
> ---
>  gnu/packages/emacs-xyz.scm | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index d0851a480e..0723639b8f 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -16227,11 +16227,11 @@ (define-public emacs-auth-source-xoauth2
>  (define-public emacs-circe
>    ;; The latest stable release is two years old, and some important fixes have
>    ;; landed since then.
> -  (let ((commit "d6f1fa18646f6ed2a1c0f06a4888130bd694ff19")
> -        (revision "0"))
> +  (let ((commit "710f057fedae6e9b820cce9336fef24b7d057e4c")
> +        (revision "1"))
>      (package
>        (name "emacs-circe")
> -      (version (git-version "2.11" revision commit))
> +      (version (git-version "2.12" revision commit))

Looks like you forgot to update the hash.  Could you send an updated
patch?

TIA!

Ludo’.
jgart May 6, 2022, 4:30 p.m. UTC | #2
On Fri, 06 May 2022 10:23:45 +0200 Ludovic Courtès <ludo@gnu.org> wrote:
> jgart <jgart@dismail.de> skribis:
> 
> > * gnu/packages/emacs-xyz.scm (emacs-circe): Update to 2.12.
> > ---
> >  gnu/packages/emacs-xyz.scm | 6 +++---
> >  1 file changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> > index d0851a480e..0723639b8f 100644
> > --- a/gnu/packages/emacs-xyz.scm
> > +++ b/gnu/packages/emacs-xyz.scm
> > @@ -16227,11 +16227,11 @@ (define-public emacs-auth-source-xoauth2
> >  (define-public emacs-circe
> >    ;; The latest stable release is two years old, and some important fixes have
> >    ;; landed since then.
> > -  (let ((commit "d6f1fa18646f6ed2a1c0f06a4888130bd694ff19")
> > -        (revision "0"))
> > +  (let ((commit "710f057fedae6e9b820cce9336fef24b7d057e4c")
> > +        (revision "1"))
> >      (package
> >        (name "emacs-circe")
> > -      (version (git-version "2.11" revision commit))
> > +      (version (git-version "2.12" revision commit))
> 
> Looks like you forgot to update the hash.  Could you send an updated
> patch?

Hi Ludo,

Thanks for the review.

I've run into this issue before that no matter what I do to try to get
guix to detect the faulty hash it happily builds the package in question
successfully without failing.

For example, I tried changing the first character of the hash to 1
if 0 in order to cause it to fail but guix does not complain and builds
it nonetheless.

Is this because of some caching going on? What should I do?

all best,

jgart
Ludovic Courtès May 9, 2022, 8:29 a.m. UTC | #3
Hi,

jgart <jgart@dismail.de> skribis:

> I've run into this issue before that no matter what I do to try to get
> guix to detect the faulty hash it happily builds the package in question
> successfully without failing.

Since ‘origin’ has a ‘file-name’ field that is a function of the version
string, Guix will try to redownload the source if you change the version
string, and at that point it should fail with a wrong hash error, as it
did for me.

Let me know if you observe something different.

HTH,
Ludo’.
Maxim Cournoyer July 7, 2022, 8:30 p.m. UTC | #4
Hello,

jgart <jgart@dismail.de> writes:

> * gnu/packages/emacs-xyz.scm (emacs-circe): Update to 2.12.
> ---
>  gnu/packages/emacs-xyz.scm | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index d0851a480e..0723639b8f 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -16227,11 +16227,11 @@ (define-public emacs-auth-source-xoauth2
>  (define-public emacs-circe
>    ;; The latest stable release is two years old, and some important fixes have
>    ;; landed since then.
> -  (let ((commit "d6f1fa18646f6ed2a1c0f06a4888130bd694ff19")
> -        (revision "0"))
> +  (let ((commit "710f057fedae6e9b820cce9336fef24b7d057e4c")
> +        (revision "1"))
>      (package
>        (name "emacs-circe")
> -      (version (git-version "2.11" revision commit))
> +      (version (git-version "2.12" revision commit))
>        (source
>         (origin
>           (method git-fetch)

Obsoleted by commit 96eb2337b5, which updated emacs-circe to 2.12.

Thanks,

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d0851a480e..0723639b8f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16227,11 +16227,11 @@  (define-public emacs-auth-source-xoauth2
 (define-public emacs-circe
   ;; The latest stable release is two years old, and some important fixes have
   ;; landed since then.
-  (let ((commit "d6f1fa18646f6ed2a1c0f06a4888130bd694ff19")
-        (revision "0"))
+  (let ((commit "710f057fedae6e9b820cce9336fef24b7d057e4c")
+        (revision "1"))
     (package
       (name "emacs-circe")
-      (version (git-version "2.11" revision commit))
+      (version (git-version "2.12" revision commit))
       (source
        (origin
          (method git-fetch)