diff mbox series

[bug#55182,3/3] gnu: apl: Use G-expressions.

Message ID 20220429115646.539143-2-paul@apatience.com
State Accepted
Headers show
Series [bug#55182,1/3] gnu: apl: Update to 1.8-r1550. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 29, 2022, 11:56 a.m. UTC
* gnu/packages/apl.scm (apl)[arguments]: Use G-expressions.
---
 gnu/packages/apl.scm | 37 +++++++++++++++++++------------------
 1 file changed, 19 insertions(+), 18 deletions(-)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/apl.scm b/gnu/packages/apl.scm
index 9c4b9a48e1..86a5adc90e 100644
--- a/gnu/packages/apl.scm
+++ b/gnu/packages/apl.scm
@@ -23,6 +23,7 @@  (define-module (gnu packages apl)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix git-download)
   #:use-module (guix svn-download)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages gettext)
@@ -54,24 +55,24 @@  (define-public apl
              readline
              sqlite))
       (arguments
-       `(#:configure-flags (list (string-append
-                                  "--with-sqlite3="
-                                  (assoc-ref %build-inputs "sqlite")))
-         #:phases
-         (modify-phases %standard-phases
-           (add-before 'configure 'fix-configure
-             (lambda _
-               (substitute* "buildtag.sh"
-                 ;; Don't exit on failed SVN-related calls.
-                 (("^ +return 0\n") "")
-                 ;; Manually set the SVN revision, since the directory is
-                 ;; unversioned and we know it anyway.
-                 (("^SVNINFO=.*")
-                  ,(string-append "SVNINFO=" (number->string revision) "\n"))
-                 ;; Requires running ‘svn info’ on a versioned directory.
-                 (("\\\\\"\\$ARCHIVE_SVNINFO\\\\\"") "\\\"\\\"")
-                 ;; Don't leak build information.
-                 (("\\\\\"\\$abs_srcdir\\\\\"") "\\\"\\\"")))))))
+       (list #:configure-flags #~(list (string-append
+                                        "--with-sqlite3="
+                                        #$(this-package-input "sqlite")))
+             #:phases
+             #~(modify-phases %standard-phases
+                 (add-before 'configure 'fix-configure
+                   (lambda _
+                     (substitute* "buildtag.sh"
+                       ;; Don't exit on failed SVN-related calls.
+                       (("^ +return 0\n") "")
+                       ;; Manually set the SVN revision, since the directory is
+                       ;; unversioned and we know it anyway.
+                       (("^SVNINFO=.*")
+                        (string-append "SVNINFO=" #$(number->string revision) "\n"))
+                       ;; Requires running ‘svn info’ on a versioned directory.
+                       (("\\\\\"\\$ARCHIVE_SVNINFO\\\\\"") "\\\"\\\"")
+                       ;; Don't leak build information.
+                       (("\\\\\"\\$abs_srcdir\\\\\"") "\\\"\\\"")))))))
       (synopsis "APL interpreter")
       (description
        "GNU APL is a free interpreter for the programming language APL.  It is