diff mbox series

[bug#55185] gnu: Add r-zlog.

Message ID 20220429112732.14803-1-navid.afkhami@mdc-berlin.de
State Accepted
Headers show
Series [bug#55185] gnu: Add r-zlog. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

nafkhamdc April 29, 2022, 11:27 a.m. UTC
* gnu/packages/cran.scm (r-zlog): New variable.
---
 gnu/packages/cran.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 03f660027cb8abcdec0bd5acf466b3956cc2752c

Comments

Ricardo Wurmus April 29, 2022, 4:25 p.m. UTC | #1
Hi Navid,

> * gnu/packages/cran.scm (r-zlog): New variable.

looks good to me, thank you!

I applied it.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1609682b8d..a828a9b4a7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6485,6 +6485,28 @@  right-hand side of an assignment into multiple values and assigns these values
 to variables on the left-hand side of the assignment.")
     (license license:expat)))
 
+(define-public r-zlog
+  (package
+    (name "r-zlog")
+    (version "1.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "zlog" version))
+              (sha256
+               (base32
+                "1d5j31p0h3rrn230087h3ngpvwknlisjv0f1qdbicdj9m177spci"))))
+    (properties `((upstream-name . "zlog")))
+    (build-system r-build-system)
+    (native-inputs (list r-knitr))
+    (home-page "https://cran.r-project.org/package=zlog")
+    (synopsis "Transformation for laboratory easurements")
+    (description
+     "The @code{zlog} package offers functions to transform laboratory
+measurements into standardised z or @math{z(log)-values}.  Therefore the lower
+and upper reference limits are needed.  If these are not known they could
+estimated from a given sample.")
+    (license license:gpl3+)))
+
 (define-public r-vctrs
   (package
     (name "r-vctrs")