diff mbox series

[bug#50080,v2,1/4] gnu: petsc-openmpi: Fix inputs.

Message ID 20220428171109.217461-2-paul@apatience.com
State Accepted
Headers show
Series gnu: sundials: Fix various issues and update to 6.2.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 28, 2022, 5:11 p.m. UTC
* gnu/packages/maths.scm (petsc-openmpi)[inputs]: Move
hdf5-parallel-openmpi from here...
[propagated-inputs]: ...to here.
---
 gnu/packages/maths.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

--
2.36.0

Comments

M April 30, 2022, 9:02 a.m. UTC | #1
Paul A. Patience schreef op do 28-04-2022 om 17:11 [+0000]:
> +     (list hdf5-parallel-openmpi)) ; petsclayouthdf5.h includes H5Ipublic.h.

This can be solved without propagation, see
<https://issues.guix.gnu.org/54780#18>
and <https://issues.guix.gnu.org/54780#19>.

Greetings,
Maxime.
Paul A. Patience May 2, 2022, 1:56 p.m. UTC | #2
On 2022-04-30 05:02:55-04:00, Maxime Devos wrote:
> Paul A. Patience schreef op do 28-04-2022 om 17:11 [+0000]:
>> +     (list hdf5-parallel-openmpi)) ; petsclayouthdf5.h includes H5Ipublic.h.
>
> This can be solved without propagation, see
> <https://issues.guix.gnu.org/54780#18>
> and <https://issues.guix.gnu.org/54780#19>.

I fixed this in v3 for petsc-openmpi, but note that one of the issues
fixed in the sundials-openmpi package (patch 2/4) is moving some
dependencies from inputs to propagated inputs to fix header inclusions.
However, those inputs would be more fragile to fix manually than
petsc-openmpi, because there are more headers to deal with than in
petsc-openmpi, and so they should probably be fixed only when the
absolute-inclusions patch is merged.

There are probably many other instances of this; I know that at least
dealii has propagated inputs just because of header inclusions.

If the absolute-inclusions patch is merged soon, I could update this
patch series to use that, but otherwise it could be fixed in a future
update to sundials (which seems to happen often).

Best regards,
Paul
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index fcd9c5482f..593bb4651c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3139,14 +3139,15 @@  (define-public petsc-openmpi
     (name "petsc-openmpi")
     (inputs
      (modify-inputs (package-inputs petsc)
-       (prepend hdf5-parallel-openmpi
-                hypre-openmpi
+       (prepend hypre-openmpi
                 metis
                 mumps-openmpi
                 openmpi
                 scalapack
                 pt-scotch32
                 `(,pt-scotch32 "metis"))))
+    (propagated-inputs
+     (list hdf5-parallel-openmpi)) ; petsclayouthdf5.h includes H5Ipublic.h.
     (arguments
      (substitute-keyword-arguments (package-arguments petsc)
        ((#:configure-flags cf)