diff mbox series

[bug#55164] gnu: Add emacs-sanityinc-tomorrow.

Message ID 20220428112623.23172-1-kefironpremise@gmail.com
State New
Headers show
Series [bug#55164] gnu: Add emacs-sanityinc-tomorrow. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Adam Kandur April 28, 2022, 11:26 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-sanityinc-tomorrow): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Liliana Marie Prikler May 13, 2022, 6:47 p.m. UTC | #1
Hi,

Am Donnerstag, dem 28.04.2022 um 14:26 +0300 schrieb Adam Kandur:
> [...]
> +    (synopsis "A set of comprehensive Emacs color themes based on
> Chris Kempson's 'tomorrow' themes")
Pretty long synopsis, don't you think?  Also note that "A" and "The"
are usually frowned upon at the start of a synopsis.
> +    (description
> +     "An Emacs version of Chris Kempson's 'Tomorrow' themes,with
> much
> +more extensive face definitions than the 'official' Emacs variant.
> +The themes work with both the built-in theming support in recent
> Emacsen,
> +and via the traditional color-theme.el add-on library in older
> versions,
> +so use whichever you prefer.")
Note that Guix doesn't have "Chris Kempson's 'Tomorrow' themes", at
least not the version this package is referring to.  We do have base16-
themes, which have an updated version of tomorrow for comparison.
Also, the description should consist of full sentence.  The usual
workaround here is "This package provides [...]", but you can more or
less feel free to do whatever as long as it's actually describing the
package and not marketing it instead.  For instance, "SanityInc
Tomorrow provides variations of Chris Kempson's Tomorrow theme (which
themselves are distributed as part of @code{emacs-base16-themes}) with
[distinctive features]".

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index db1663c..2b8b575 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3649,6 +3649,30 @@  (define-public emacs-saveplace-pdf-view
 restore the saved place.")
     (license license:gpl3+)))
 
+(define-public emacs-sanityinc-tomorrow
+  (package
+    (name "emacs-sanityinc-tomorrow")
+    (version "1.17")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+	     (url "https://github.com/purcell/color-theme-sanityinc-tomorrow")
+	     (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+	(base32 "1x3aq6hadp158vh8mf9hmj5rikq0qz7a1frv7vbl39xr3wcnjj23"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/purcell/color-theme-sanityinc-tomorrow")
+    (synopsis "A set of comprehensive Emacs color themes based on Chris Kempson's 'tomorrow' themes")
+    (description
+     "An Emacs version of Chris Kempson's 'Tomorrow' themes,with much
+more extensive face definitions than the 'official' Emacs variant.
+The themes work with both the built-in theming support in recent Emacsen,
+and via the traditional color-theme.el add-on library in older versions,
+so use whichever you prefer.")
+    (license license:gpl3+)))
+
 (define-public emacs-dash
   (package
     (name "emacs-dash")