diff mbox series

[bug#55154] gnu: Add r-afpt.

Message ID 20220427144001.43082-1-navid.afkhami@mdc-berlin.de
State Accepted
Headers show
Series [bug#55154] gnu: Add r-afpt. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

nafkhamdc April 27, 2022, 2:40 p.m. UTC
From: Navid <navid.afkhami@mdc-berlin.de>

* gnu/packages/cran.scm (r-afpt): New variable.
---
 gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Ricardo Wurmus April 29, 2022, 4:13 p.m. UTC | #1
Hi Navid,

> From: Navid <navid.afkhami@mdc-berlin.de>
>
> * gnu/packages/cran.scm (r-afpt): New variable.

Thank you, this is an excellent first contribution!

I applied it and pushed to the “master” branch with commit
325d53d5f634f6490e3291304fb5522400039224.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bc95eee065..e7d3fc19e0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -35,6 +35,7 @@ 
 ;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
 ;;; Copyright © 2021 Marcel Schilling <marcel.schilling@uni-luebeck.de>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Navid Afkhami  <navid.afkhami@mdc-berlin.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -112,6 +113,30 @@ 
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
+(define-public r-afpt
+  (package
+    (name "r-afpt")
+    (version "1.1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "afpt" version))
+              (sha256
+               (base32
+                "0cg5cdm9nl1hs6f3j0ljpw4bkqvh3ksyj615b9nnbqs5k28lyds9"))))
+    (properties `((upstream-name . "afpt")))
+    (build-system r-build-system)
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/MarcoKlH/afpt-r/")
+    (synopsis "Tools for modelling of animal flight performance")
+    (description
+     "This package allows estimation and modelling of flight costs in animal
+(vertebrate) flight, implementing the aerodynamic power model.  Flight
+performance is estimated based on basic morphological measurements such as body
+mass, wingspan and wing area.  @code{Afpt} can be used to make predictions on
+how animals should adjust their flight behaviour and wingbeat kinematics to
+varying flight conditions.")
+    (license license:gpl3+)))
+
 (define-public r-aod
   (package
     (name "r-aod")