diff mbox series

[bug#55152] gnu: Add emacs-soothe-theme.

Message ID 20220427133137.2603-1-kefironpremise@gmail.com
State Accepted
Headers show
Series [bug#55152] gnu: Add emacs-soothe-theme. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Adam Kandur April 27, 2022, 1:31 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-soothe-theme): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou June 27, 2022, 10:27 a.m. UTC | #1
Hello,

Adam Kandur <kefironpremise@gmail.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-soothe-theme): New variable.

Thank you. Sorry for the delay. Some comments follow.

> +(define-public emacs-soothe-theme
> +  (let ((commit "0786fe70c6c1b4ddcfb932fdc6862b9611cfc09b")
> +        (revision "0"))
> +    (package
> +      (name "emacs-soothe-theme")
> +      (version (git-version "0.1" revision commit))

Where does this "0.1" come from? According to "soothe-theme.el" and
Changelog, version is 20141027.2233.

Also, I suggest to stick to commit hash
0568a61eeec0b074d8911886359a6c5da13d14cb, which is the penultimate
commit, but matches version bump. You don't need to use `git-version'
then.

> +      (source
> +       (origin
> +	 (method git-fetch)
> +	 (uri (git-reference
> +	       (url "https://github.com/emacsfodder/emacs-soothe-theme.git")

You can drop the ".git" suffix from the URL.

> +	       (commit commit)))
> +	 (file-name (git-file-name name version))
> +	 (sha256
> +	  (base32 "10gh1hvxq9gm29r6qzlnva7vjidd7n4kih4z2ihyvbvy9za20xqw"))))
> +      (build-system emacs-build-system)
> +      (home-page "https://github.com/emacsfodder/emacs-soothe-theme.git")
> +      (synopsis "A colorful, but muted theme for Emacs 24, dark background with light text")

Synopsis must not start with an article. I would also remove reference
to Emacs 24, which is unimportant in Guix.

> +      (description
> +       "An amalgam of muted color tones and highlighted backgrounds.  Builtin support 
> +for rainbow-delimiters, org-mode, whitespace-mode, ECB, flyspell, ido, linum, highlight
> +indentation, show-paren-mode, further mode support to come.")

Description must contain complete sentence only. So it should be "Soothe
theme is an amalgam…".

Also (nitpick) major mode are usually capitalized and un-hyphenized at
least in the Emacs manual. So: Rainbom delimiters, Org mode, Whitespace
mode, Flyspell, Ido, Linum…

Since the project hasn't seen any commit in the last 7 years, maybe
"further mode support to come" should be removed.

> +      (license license:gpl3+))))

License seems to be gpl3, not gpl3+.

Could you send an updated patch?

Regards,
Nicolas Goaziou July 20, 2022, 1:01 p.m. UTC | #2
Hello,

You sent me the updated patch in private. I applied it. Thank you.

Closing,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index db1663c..34658e4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1482,6 +1482,30 @@  (define-public emacs-solidity
 a constant work in progress as the language itself also progresses.")
       (license license:gpl3+))))
 
+(define-public emacs-soothe-theme
+  (let ((commit "0786fe70c6c1b4ddcfb932fdc6862b9611cfc09b")
+        (revision "0"))
+    (package
+      (name "emacs-soothe-theme")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+	 (method git-fetch)
+	 (uri (git-reference
+	       (url "https://github.com/emacsfodder/emacs-soothe-theme.git")
+	       (commit commit)))
+	 (file-name (git-file-name name version))
+	 (sha256
+	  (base32 "10gh1hvxq9gm29r6qzlnva7vjidd7n4kih4z2ihyvbvy9za20xqw"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/emacsfodder/emacs-soothe-theme.git")
+      (synopsis "A colorful, but muted theme for Emacs 24, dark background with light text")
+      (description
+       "An amalgam of muted color tones and highlighted backgrounds.  Builtin support 
+for rainbow-delimiters, org-mode, whitespace-mode, ECB, flyspell, ido, linum, highlight
+indentation, show-paren-mode, further mode support to come.")
+      (license license:gpl3+))))
+
 (define-public emacs-unpackaged-el
   (let ((commit "746801a677ada6cd6fa076e423aa0953779f3fad")
         (revision "3"))