diff mbox series

[bug#55121] gnu: Add r-adamgui.

Message ID 20220426101954.8271-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#55121] gnu: Add r-adamgui. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu April 26, 2022, 10:19 a.m. UTC
* gnu/packages/bioconductor.scm (r-adamgui): New variable.
---
 gnu/packages/bioconductor.scm | 47 +++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)


base-commit: 30ff557bd7255dddec16f4a032e58f5a88d5e448

Comments

Ricardo Wurmus April 26, 2022, 9:48 p.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/bioconductor.scm (r-adamgui): New variable.

Thanks for the patch!  Pushed with minor stylistic changes.
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index fa862d736f..484fb2e0a6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1616,6 +1616,53 @@  (define-public r-adam
 functionally associated genes} (GFAG).")
     (license license:gpl2+)))
 
+(define-public r-adamgui
+  (package
+    (name "r-adamgui")
+    (version "1.10.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "ADAMgui" version))
+              (sha256
+               (base32
+                "0n06bb9djigha0249lxx84pn9q0xiryxbv25qsc3p2h46iaxi3wq"))))
+    (properties `((upstream-name . "ADAMgui")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-adam
+                             r-colorramps
+                             r-data-table
+                             r-dplyr
+                             r-dt
+                             r-ggplot2
+                             r-ggpubr
+                             r-ggrepel
+                             r-ggsignif
+                             r-go-db
+                             r-gridextra
+                             r-knitr
+                             r-rcolorbrewer
+                             r-reshape2
+                             r-shiny
+                             r-shinyjs
+                             r-stringi
+                             r-stringr
+                             r-testthat
+                             r-varhandle))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/ADAMgui/")
+    (synopsis
+     "Graphical user interface for gene activity and diversity analysis module")
+    (description
+     "This package @code{ADAMgui} is a @dfn{graphical user interface} (GUI) for
+the @code{ADAM} package.  The @code{ADAMgui} package provides 2 shiny-based
+applications that allows the user to study the output of the @code{ADAM}
+package files through different plots.  It's possible, for example, to choose a
+specific @dfn{group of functionally associated genes} (GFAG) and observe the
+gene expression behavior with the plots created with the @code{GFAGtargetUi}
+function.  Features such as differential expression and fold change can be
+easily seen with aid of the plots made with @code{GFAGpathUi} function.")
+    (license license:gpl2+)))
+
 (define-public r-aneufinder
   (package
     (name "r-aneufinder")