diff mbox series

[bug#55108] gnu: Add python-style.

Message ID 20220425081556.23286-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#55108] gnu: Add python-style. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart April 25, 2022, 8:15 a.m. UTC
* gnu/packages/python-xyz.scm (python-style): New variable.

Co-authored-by: Yuchen Pei <hi@ypei.me>
Co-authored-by: donotshake <dns@0cool.club>
Co-authored-by: Vagrant Cascadian <vagrant@debian.org>
Co-authored-by: Pranav Vats <pranavats@disroot.org>

Hi Guixers,

Here's one patch from today's packaging meetup. More to come!

all best,

jgart

https://whereis.みんな/
gemini://whereis.みんな/

---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

Mathieu Othacehe May 9, 2022, 7:36 a.m. UTC | #1
Hello,

> +"@code{python-style} is a simple terminal string styling package.  Its
> +API is a port of the popular chalk package for javascript.")

I removed the word "popular" and pushed.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3fab1457dd..313994b7e3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29512,6 +29512,24 @@  (define-public python-shtab
 Python CLI apps.")
     (license license:asl2.0)))
 
+(define-public python-style
+  (package
+    (name "python-style")
+    (version "1.1.6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "style" version))
+        (sha256
+          (base32 "1dcfb578v9mrwh92rgms87gql0gp4vgj6l9hpgyfg0wbd3rh3bfh"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/lmittmann/style")
+    (synopsis "Terminal string styling")
+    (description
+"@code{python-style} is a simple terminal string styling package.  Its
+API is a port of the popular chalk package for javascript.")
+    (license license:expat)))
+
 (define-public python-sre-yield
   (package
     (name "python-sre-yield")