diff mbox series

[bug#55099] gnu: guile-srfi-189: Build from upstream sources.

Message ID 20220424215035.22373-1-attila@lendvai.name
State Accepted
Headers show
Series [bug#55099] gnu: guile-srfi-189: Build from upstream sources. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Attila Lendvai April 24, 2022, 9:50 p.m. UTC
* gnu/packages/guile-xyz.scm (guile-srfi-189): Retarget git-reference to the
official repo, and increase revision by one.
---
 gnu/packages/guile-xyz.scm | 14 +++++---------
 1 file changed, 5 insertions(+), 9 deletions(-)

Comments

Mathieu Othacehe April 26, 2022, 7:19 a.m. UTC | #1
> * gnu/packages/guile-xyz.scm (guile-srfi-189): Retarget git-reference to the
> official repo, and increase revision by one.

Pushed, thanks!

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 3299b6cb74..62397e2125 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3237,21 +3237,17 @@  (define-public guile-srfi-180
       (license license:expat))))
 
 (define-public guile-srfi-189
-  (let ((commit "a0e3786702956c9e510d92746474ac988c2010ec")
-        (revision "0"))
+  (let ((commit "659e3cd0fc2bfca9085424eda8cad804ead2a9ea")
+        (revision "1"))
     (package
       (name "guile-srfi-189")
-      (version (git-version "0" revision commit))
+      ;; 'final' is the name of the latest git tag.
+      (version (git-version "final" revision commit))
       (source
        (origin
          (method git-fetch)
          (uri (git-reference
-               ;; This is a fork of:
-               ;; (url "https://github.com/scheme-requests-for-implementation/srfi-189")
-               ;; Upstream merge requested at:
-               ;; https://github.com/scheme-requests-for-implementation/srfi-189/pull/21
-               ;; TODO switch over to the official repo when the PR gets merged
-               (url "https://github.com/attila-lendvai-patches/srfi-189")
+               (url "https://github.com/scheme-requests-for-implementation/srfi-189")
                (commit commit)))
          (sha256
           (base32