diff mbox series

[bug#55087] gnu: Add grsync.

Message ID 20220424015405.6006-1-tumashu@163.com
State Accepted
Headers show
Series [bug#55087] gnu: Add grsync. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Feng Shu April 24, 2022, 1:54 a.m. UTC
From: Feng Shu <tumashu@163.com>

* gnu/packages/backup.scm (grsync): New variable.
---
 gnu/packages/backup.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Mathieu Othacehe April 26, 2022, 7:29 a.m. UTC | #1
> * gnu/packages/backup.scm (grsync): New variable.

I added your copyright, wrapped the description and pushed,

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 36bb2ae8e2..51d6de6b43 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -71,6 +71,7 @@  (define-module (gnu packages backup)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages golang)
   #:use-module (gnu packages gperf)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages guile-xyz)
   #:use-module (gnu packages linux)
@@ -1340,3 +1341,26 @@  (define-public vorta
 scheduled backups, and has a graphical tool for browsing and extracting the Borg
 archives.")
     (license license:gpl3+)))
+
+(define-public grsync
+  (package
+    (name "grsync")
+    (version "1.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.opbyte.it/release/"
+                                  "grsync-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1z1m782b50x348kgynzf753apy8yszkl31y32y1jsc055skcdixp"))))
+    (build-system gnu-build-system)
+    (native-inputs (list intltool pkg-config))
+    (inputs (list gtk+))
+    (propagated-inputs (list rsync))
+    (home-page "http://www.opbyte.it/grsync/")
+    (synopsis "GTK frontend for rsync")
+    (description
+     "Grsync is a simple graphical interface using GTK for the rsync command line
+program.  It currently supports only a limited set of the most important rsync
+features, but can be used effectively for local directory synchronization.")
+    (license license:gpl2)))