diff mbox series

[bug#55084] gnu: python-numpy-next: Update to 1.22.3.

Message ID 20220423164805.17075-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#55084] gnu: python-numpy-next: Update to 1.22.3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber April 23, 2022, 4:48 p.m. UTC
* gnu/packages/python-xyz.scm (python-numpy-next): Update to 1.22.3.
[native-inputs]: Replace python-hypothesis with python-hypothesis-6.23.
* gnu/packages/python-xyz.scm (python-numpy-1.20)[native-inputs]:
Explicitly set native-inputs to prevent it to inherit the modified
native-inputs from python-numpy-next, which would result in > 2000
package rebuilds.
---
 gnu/packages/python-xyz.scm | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

Comments

Mathieu Othacehe April 26, 2022, 9:22 a.m. UTC | #1
Hello Felix,

> +    (native-inputs
> +     (list python-cython python-hypothesis python-pytest
> +           python-pytest-xdist gfortran))

What about using something like:

--8<---------------cut here---------------start------------->8---
    (native-inputs
     (modify-inputs (package-inputs python-numpy-next)
       (delete "python-hypothesis")
       (prepend python-hypothesis)))
--8<---------------cut here---------------end--------------->8---

not to duplicate the native-inputs list?

Thanks,

Mathieu
Simon Tournier April 26, 2022, 10:59 a.m. UTC | #2
Hi Mathieu,

On Tue, 26 Apr 2022 at 11:23, Mathieu Othacehe <othacehe@gnu.org> wrote:

> > +    (native-inputs
> > +     (list python-cython python-hypothesis python-pytest
> > +           python-pytest-xdist gfortran))
>
> What about using something like:
>
> --8<---------------cut here---------------start------------->8---
>     (native-inputs
>      (modify-inputs (package-inputs python-numpy-next)
>        (delete "python-hypothesis")
>        (prepend python-hypothesis)))
> --8<---------------cut here---------------end--------------->8---
>
> not to duplicate the native-inputs list?

I do not think it is possible because, whereas this 'modify-inputs' is
better for readibility, it implies a rebuild of the package, IMHO; the
very thing we would like to avoid since touching to python-numpy is a
core-update modification.

However, maybe python-numpy-next could inherit from python-numpy
instead of the contrary.  Well, I do not know if it is better...


Cheers,
simon
Ludovic Courtès May 9, 2022, 10:26 a.m. UTC | #3
Hi,

Felix Gruber <felgru@posteo.net> skribis:

> * gnu/packages/python-xyz.scm (python-numpy-next): Update to 1.22.3.
> [native-inputs]: Replace python-hypothesis with python-hypothesis-6.23.
> * gnu/packages/python-xyz.scm (python-numpy-1.20)[native-inputs]:
> Explicitly set native-inputs to prevent it to inherit the modified
> native-inputs from python-numpy-next, which would result in > 2000
> package rebuilds.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9a5d311680..3f984c03e2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5667,7 +5667,7 @@  writing C extensions for Python as easy as Python itself.")
 (define-public python-numpy-next
   (package
     (name "python-numpy-next")
-    (version "1.21.3")
+    (version "1.22.3")
     (source
      (origin
        (method url-fetch)
@@ -5676,12 +5676,12 @@  writing C extensions for Python as easy as Python itself.")
              version "/numpy-" version ".tar.gz"))
        (sha256
         (base32
-         "0s6hy8828yr7fcjiwnym4l8lrknr21gqfkaiawsf86n0hd0a5fyh"))))
+         "19dw91pqbqcniw2z57kiyqs1qp56g7kqy1bdyv664g8s62sc01m9"))))
     (build-system python-build-system)
     (inputs
      (list openblas))
     (native-inputs
-     (list python-cython python-hypothesis python-pytest
+     (list python-cython python-hypothesis-6.23 python-pytest
            python-pytest-xdist gfortran))
     (arguments
      `(#:phases
@@ -5773,6 +5773,12 @@  capabilities.")
               (sha256
                (base32
                 "140zq9snx0di4id4g97vaw9zz8x2rfla5lp3a70j666f5030yd5p"))))
+    ;; python-numpy-next replaced python-hypothesis with
+    ;; python-hypothesis-6.23. We switch it back here, to prevent
+    ;; python-numpy-1.20 and its numerous dependents from being rebuilt.
+    (native-inputs
+     (list python-cython python-hypothesis python-pytest
+           python-pytest-xdist gfortran))
     ;; 92 tests fail, many of them because parts of the temp file name
     ;; accidentally ends up in a comparison.
     (arguments