diff mbox series

[bug#54869,v3,6/7] gnu: python-vedo: Disable sanity check.

Message ID 20220422202538.106338-7-paul@apatience.com
State Accepted
Headers show
Series gnu: python-vedo: Update to 2022.2.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 22, 2022, 8:26 p.m. UTC
* gnu/packages/python-science.scm (python-vedo)[arguments]: Disable
sanity check.
---
 gnu/packages/python-science.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

--
2.35.1
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 3afaa0efc2..676ca6474e 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -884,7 +884,11 @@  (define-public python-vedo
                  (for-each (lambda (dir)
                              (with-directory-excursion dir
                                (invoke "./run_all.sh")))
-                           '("common" "dolfin")))))))))
+                           '("common" "dolfin"))))))
+         ;; Disable the sanity check, which fails with the following error:
+         ;;
+         ;;   ...checking requirements: ERROR: vedo==2021.0.3 DistributionNotFound(Requirement.parse('vtk'), {'vedo'})
+         (delete 'sanity-check))))
     (inputs        ; for the check phase
      (list fenics
            python-matplotlib