diff mbox series

[bug#55005,01/13] gnu: Add ghc-primes

Message ID 20220418180957.19545-1-thomas@thomaslabs.org
State New
Headers show
Series gnu: Add multiple haskell packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thomas Albers Raviola April 18, 2022, 6:09 p.m. UTC
---
 gnu/packages/haskell-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 0ce47e0902..beba6a5d0c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -30,6 +30,7 @@ 
 ;;; Copyright © 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2021 Alice BRENON <alice.brenon@ens-lyon.fr>
 ;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -16105,3 +16106,23 @@  (define-public ghc-singleton-bool
      "This package provides Type-level booleans.")
     (license license:bsd-3)))
 
+(define-public ghc-primes
+  (package
+    (name "ghc-primes")
+    (version "0.2.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/primes/primes-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32 "0ny6fzr967d1fifk050k95j9snnbjjif2bxf3v9s93k3zdc6bmkl"))))
+    (build-system haskell-build-system)
+    (outputs '("out" "static"))
+    (home-page "https://github.com/sebfisch/primes")
+    (synopsis "Purely functional generation of prime numbers")
+    (description
+     "This library provides an efficient lazy wheel sieve for prime generation.")
+    (license license:bsd-3)))