diff mbox series

[bug#54995] gnu: Add cl-ipfs-api2.

Message ID 20220417184748.14902-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54995] gnu: Add cl-ipfs-api2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

jgart April 17, 2022, 6:47 p.m. UTC
* gnu/packages/lisp-xyz.scm (cl-ipfs-api2): New variable.
---
 gnu/packages/lisp-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

Comments

Guillaume Le Vaillant April 18, 2022, 7:27 a.m. UTC | #1
Patch pushed as b629b302696605201b270439bf8e4f958547a88f with a few
modifications (the 'asd-files' and 'asd-systems' parameters were not
necessary in this case).
Thanks.
M April 18, 2022, 9:23 a.m. UTC | #2
jgart via Guix-patches via schreef op zo 17-04-2022 om 14:47 [-0400]:
> +(which uses the locally installed go-ipfs program).")

go-ipfs is missing from the inputs and would need to be patched into
<https://github.com/JadedCtrl/cl-ipfs-api2/blob/master/main.lisp#L14>
or <https://github.com/JadedCtrl/cl-ipfs-api2/blob/master/main.lisp#L837>
(not sure where exactly) such that 'cl-ipfs-api2' works without 'ipfs'
being in $PATH.

Greetings,
Maxime.
jgart April 18, 2022, 5:12 p.m. UTC | #3
On Mon, 18 Apr 2022 11:23:36 +0200 Maxime Devos <maximedevos@telenet.be> wrote:
> jgart via Guix-patches via schreef op zo 17-04-2022 om 14:47 [-0400]:
> > +(which uses the locally installed go-ipfs program).")
> 
> go-ipfs is missing from the inputs and would need to be patched into
> <https://github.com/JadedCtrl/cl-ipfs-api2/blob/master/main.lisp#L14>
> or <https://github.com/JadedCtrl/cl-ipfs-api2/blob/master/main.lisp#L837>
> (not sure where exactly) such that 'cl-ipfs-api2' works without 'ipfs'
> being in $PATH.

Thanks for catching that. I didn't realize it was a dependency.

I'll send an updated patch soon.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 82270b3e32..5a6a344d4c 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20940,6 +20940,44 @@  (define-public cl-simple-routes
 (define-public ecl-simple-routes
   (sbcl-package->ecl-package sbcl-simple-routes))
 
+(define-public sbcl-cl-ipfs-api2
+  (let ((commit "3ee52c80023bcc662f7d01276ea0a5814bd0011b")
+        (revision "0"))
+    (package
+      (name "sbcl-cl-ipfs-api2")
+      (version (git-version "0.51" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/JadedCtrl/cl-ipfs-api2")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1h0csxk4db1hid793mk5kz3nbjyl7z4ic1zk2wy46k1vz5lnnsph"))))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       '(#:tests? #f ; There are no tests.
+         #:asd-files '("cl-ipfs-api2.asd")
+         #:asd-systems '("cl-ipfs-api2")))
+      (inputs
+        (list sbcl-drakma
+              sbcl-yason
+              sbcl-arnesi))
+      (home-page "https://github.com/JadedCtrl/cl-ipfs-api2/")
+      (synopsis "Bindings for the IPFS HTTP API")
+      (description
+"@code{cl-sbcl-cl-ipfs-api2} is a pretty simple set of IPFS bindings for
+Common Lisp, using the HTTP API for (almost) everything, except for pubsub
+(which uses the locally installed go-ipfs program).")
+      (license license:lgpl3+))))
+
+(define-public cl-ipfs-api2
+  (sbcl-package->cl-source-package sbcl-cl-ipfs-api2))
+
+(define-public ecl-cl-ipfs-api2
+  (sbcl-package->ecl-package sbcl-cl-ipfs-api2))
+
 (define-public sbcl-purgatory
   (let ((commit "ade0d60a14a1067b9cc8cf06d1f1a1ca8cecdb03")
         (revision "1"))