diff mbox series

[bug#54980,1/1] gnu: go: Update to 1.17.9

Message ID 20220417123126.14869-1-ph@heykimo.com
State Accepted
Headers show
Series Update Go 1.17.9 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Pier-Hugues Pellerin April 17, 2022, 12:31 p.m. UTC
go1.17.9 (released 2022-04-12) includes security fixes to the
crypto/elliptic and encoding/pem packages, as well as bug fixes to
the linker and runtime.

Releases notes: https://github.com/golang/go/issues?q=milestone%3AGo1.17.9+label%3ACherryPickApproved
---
 gnu/packages/golang.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès April 29, 2022, 12:57 p.m. UTC | #1
Hi,

Pier-Hugues Pellerin <ph@heykimo.com> skribis:

> go1.17.9 (released 2022-04-12) includes security fixes to the
> crypto/elliptic and encoding/pem packages, as well as bug fixes to
> the linker and runtime.
>
> Releases notes: https://github.com/golang/go/issues?q=milestone%3AGo1.17.9+label%3ACherryPickApproved

I tweaked the commit log and applied it on the ‘staging’ branch.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f3cc1bd6b8..bfe9ee059e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -626,7 +626,7 @@  (define-public go-1.17
   (package
     (inherit go-1.16)
     (name "go")
-    (version "1.17.8")
+    (version "1.17.9")
     (source
      (origin
        (method git-fetch)
@@ -636,7 +636,7 @@  (define-public go-1.17
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "05qfs17wddxmmi349g9ci12w9fjb5vbss6qpjc4qzgqzznqf0ycy"))))
+         "02l6gxn738kam1niy2nl2wpsbzl4x87h2wik6hd3py19kq4z2flw"))))
     (outputs '("out" "tests")) ; 'tests' contains distribution tests.
     (arguments
      `(#:modules ((ice-9 match)