diff mbox series

[bug#54979] gnu: Add emacs-straight-el.

Message ID 20220417034517.12993-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54979] gnu: Add emacs-straight-el. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

jgart April 17, 2022, 3:45 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-straight-el): New variable.

Hi Guixers,

Here is straight.el

This package is also available from Guix 'R Us as a pre-release:

https://whereis.みんな/

all best,

jgart


---
 gnu/packages/emacs-xyz.scm | 40 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

Nicolas Goaziou June 23, 2022, 9:50 p.m. UTC | #1
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-straight-el): New variable.

I applied it with minor changes, detailed below.

Thank you.

> +(define-public emacs-straight-el
> +  (let ((commit "af5437f2afd00936c883124d6d3098721c2d306c")

I updated it to latest commit.

> +        (revision "0"))
> +    (package
> +      (name "emacs-straight-el")
> +      (version (git-version "0" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri
> +          (git-reference
> +           (url "https://github.com/raxod502/straight.el")
> +           (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "1mpaq373d6yl8yaqmdg634lm3vwnz0xhzcvhm85kmqk36pkpj7ij"))))
> +      (build-system emacs-build-system)
> +      (arguments
> +        (list #:phases

I also activated tests.

> +              #~(modify-phases %standard-phases
> +                  (add-after 'unpack 'patch-git-executable
> +                    (lambda* (#:key inputs #:allow-other-keys)
> +                        (make-file-writable "straight.el")
> +                        (substitute* "straight.el"
> +                          (("\"git\"")
> +                           (string-append "\""
> +                                          (search-input-file inputs "/bin/git") 
> +                                          "\""))))))))
> +      (inputs
> +        (list git))
> +      (propagated-inputs
> +        (list emacs-magit))
> +      (home-page "https://github.com/raxod502/straight.el/")
> +      (synopsis "Purely functional package manager for the Emacs hacker")
> +      (description
> +"@code{emacs-straight-el} is a next-generation, purely functional package
> +manager for the Emacs hacker.")

I removed "next-generation" buzz-word.

Regards,
jgart June 23, 2022, 10:02 p.m. UTC | #2
On Thu, 23 Jun 2022 23:50:48 +0200 Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

Thank you! Much appreciated :()

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cc145175f0..52d9e6b5af 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -108,6 +108,7 @@ 
 ;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
 ;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -30900,6 +30901,45 @@  (define-public emacs-pyimport
 "@code{emacs-pyimport} manages python imports from Emacs via @code{python-pyflakes}.")
       (license license:gpl3+)))) ; License is in pyimport.el
 
+(define-public emacs-straight-el
+  (let ((commit "af5437f2afd00936c883124d6d3098721c2d306c")
+        (revision "0"))
+    (package
+      (name "emacs-straight-el")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/raxod502/straight.el")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1mpaq373d6yl8yaqmdg634lm3vwnz0xhzcvhm85kmqk36pkpj7ij"))))
+      (build-system emacs-build-system)
+      (arguments
+        (list #:phases
+              #~(modify-phases %standard-phases
+                  (add-after 'unpack 'patch-git-executable
+                    (lambda* (#:key inputs #:allow-other-keys)
+                        (make-file-writable "straight.el")
+                        (substitute* "straight.el"
+                          (("\"git\"")
+                           (string-append "\""
+                                          (search-input-file inputs "/bin/git") 
+                                          "\""))))))))
+      (inputs
+        (list git))
+      (propagated-inputs
+        (list emacs-magit))
+      (home-page "https://github.com/raxod502/straight.el/")
+      (synopsis "Purely functional package manager for the Emacs hacker")
+      (description
+"@code{emacs-straight-el} is a next-generation, purely functional package
+manager for the Emacs hacker.")
+      (license license:expat))))
+
 (define-public emacs-osm
   (package
     (name "emacs-osm")