diff mbox series

[bug#54584,v2] gnu: python-slixmpp: Update to 1.8.1.

Message ID 20220416142609.11144-1-jgart@dismail.de
State New
Headers show
Series [bug#54584,v2] gnu: python-slixmpp: Update to 1.8.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart April 16, 2022, 2:26 p.m. UTC
* gnu/packages/python-xyz.scm (python-slixmpp): Update to 1.8.1.
[arguments]: Remove trailing boolean, use new style, and use 
cc-for-target.
[native-inputs]: Use new style.

Hi Maxim,

Here is the second version of this patch.

I think this adds what you suggested in the code review.

thanks,

jgart

---
 gnu/packages/python-xyz.scm | 25 ++++++++++++-------------
 1 file changed, 12 insertions(+), 13 deletions(-)

Comments

M April 16, 2022, 3:25 p.m. UTC | #1
jgart via Guix-patches via schreef op za 16-04-2022 om 10:26 [-0400]:
> * gnu/packages/python-xyz.scm (python-slixmpp): Update to 1.8.1.
> [arguments]: Remove trailing boolean, use new style, and use 
> cc-for-target.
> [native-inputs]: Use new style.
> 
> Hi Maxim,
> 
> Here is the second version of this patch.
> 
> I think this adds what you suggested in the code review.

I haven't looked at the upstream 1.5.2->1.8.1 diff, but the CC->cc-for-
target and delabelisation LGTM.

Greetings,
Maxime.
Maxim Cournoyer April 24, 2022, 3:32 a.m. UTC | #2
Hi jgart,

jgart <jgart@dismail.de> writes:

> * gnu/packages/python-xyz.scm (python-slixmpp): Update to 1.8.1.
> [arguments]: Remove trailing boolean, use new style, and use 
> cc-for-target.
> [native-inputs]: Use new style.
>
> Hi Maxim,
>
> Here is the second version of this patch.
>
> I think this adds what you suggested in the code review.
>
> thanks,
>
> jgart
>
> ---
>  gnu/packages/python-xyz.scm | 25 ++++++++++++-------------
>  1 file changed, 12 insertions(+), 13 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 219a0d9213..1654fc2894 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -688,7 +688,7 @@ (define-public python-mkdocs-material
>  (define-public python-slixmpp
>    (package
>      (name "python-slixmpp")
> -    (version "1.5.2")
> +    (version "1.8.1")
>      (source
>       (origin
>         (method git-fetch)
> @@ -700,21 +700,20 @@ (define-public python-slixmpp
>         (file-name
>          (git-file-name name version))
>         (sha256
> -        (base32 "15mqxcws14bjvh5jcfwl86zsvrymkdw3ya07vb44md7vfnsnclwx"))))
> +        (base32 "0723m7pbyf4xnsy381drni3kr8wm60637gn6d7fbf4i5m04jy9iy"))))
>      (build-system python-build-system)
>      (arguments
> -     `(#:phases
> -       (modify-phases %standard-phases
> -         (add-after 'unpack 'patch
> -           (lambda _
> -             (substitute* "setup.py"
> -               (("'CC', 'cc'")
> -                "'CC', 'gcc'"))
> -             #t)))))
> +      (list #:phases
> +            #~(modify-phases %standard-phases
> +                (add-after 'unpack 'patch
> +                  (lambda _
> +                    (substitute* "setup.py"
> +                      (((string-append "'CC', " #$(cc-for-target)))
> +                       ((string-append "'CC', " #$(cc-for-target))))))))))

This doesn't look right; the matched pattern is replaced by... the same
thing?

>      (native-inputs
> -     `(("cython" ,python-cython)
> -       ("gnupg" ,gnupg)
> -       ("pkg-config" ,pkg-config)))
> +      (list python-cython
> +            gnupg
> +            pkg-config))

Are you sure pkg-config is needed?  That's unusual in Python packages.

Thanks,

Maxim
jgart April 24, 2022, 6:15 a.m. UTC | #3
On Sat, 23 Apr 2022 23:32:53 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
> > +      (list #:phases
> > +            #~(modify-phases %standard-phases
> > +                (add-after 'unpack 'patch
> > +                  (lambda _
> > +                    (substitute* "setup.py"
> > +                      (((string-append "'CC', " #$(cc-for-target)))
> > +                       ((string-append "'CC', " #$(cc-for-target))))))))))
> 
> This doesn't look right; the matched pattern is replaced by... the same
> thing?

Oh yes, that was definitely a blunder. I'll send a patch fixing that soon.

> 
> >      (native-inputs
> > -     `(("cython" ,python-cython)
> > -       ("gnupg" ,gnupg)
> > -       ("pkg-config" ,pkg-config)))
> > +      (list python-cython
> > +            gnupg
> > +            pkg-config))
> 
> Are you sure pkg-config is needed?  That's unusual in Python packages.

I'll check that. That was there from the previous commit on the package.
Maxim Cournoyer May 22, 2022, 5:08 a.m. UTC | #4
Hi jgart,

jgart <jgart@dismail.de> writes:

> On Sat, 23 Apr 2022 23:32:53 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>> > +      (list #:phases
>> > +            #~(modify-phases %standard-phases
>> > +                (add-after 'unpack 'patch
>> > +                  (lambda _
>> > +                    (substitute* "setup.py"
>> > +                      (((string-append "'CC', " #$(cc-for-target)))
>> > +                       ((string-append "'CC', " #$(cc-for-target))))))))))
>> 
>> This doesn't look right; the matched pattern is replaced by... the same
>> thing?
>
> Oh yes, that was definitely a blunder. I'll send a patch fixing that soon.

Now sure if soon is now, but... ping :-)

Thanks,

Maxim
jgart May 22, 2022, 7:35 p.m. UTC | #5
On Sun, 22 May 2022 01:08:52 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
> Hi jgart,
> 
> jgart <jgart@dismail.de> writes:
> 
> > On Sat, 23 Apr 2022 23:32:53 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
> >> > +      (list #:phases
> >> > +            #~(modify-phases %standard-phases
> >> > +                (add-after 'unpack 'patch
> >> > +                  (lambda _
> >> > +                    (substitute* "setup.py"
> >> > +                      (((string-append "'CC', " #$(cc-for-target)))
> >> > +                       ((string-append "'CC', " #$(cc-for-target))))))))))
> >> 
> >> This doesn't look right; the matched pattern is replaced by... the same
> >> thing?
> >
> > Oh yes, that was definitely a blunder. I'll send a patch fixing that soon.
> 
> Now sure if soon is now, but... ping :-)

Sorry, I probably won't be able to get to this for atleast another week.

I'll let you know sooner if that changes otherwise feel free to fix it and add yourself as author to push this through.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 219a0d9213..1654fc2894 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -688,7 +688,7 @@  (define-public python-mkdocs-material
 (define-public python-slixmpp
   (package
     (name "python-slixmpp")
-    (version "1.5.2")
+    (version "1.8.1")
     (source
      (origin
        (method git-fetch)
@@ -700,21 +700,20 @@  (define-public python-slixmpp
        (file-name
         (git-file-name name version))
        (sha256
-        (base32 "15mqxcws14bjvh5jcfwl86zsvrymkdw3ya07vb44md7vfnsnclwx"))))
+        (base32 "0723m7pbyf4xnsy381drni3kr8wm60637gn6d7fbf4i5m04jy9iy"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch
-           (lambda _
-             (substitute* "setup.py"
-               (("'CC', 'cc'")
-                "'CC', 'gcc'"))
-             #t)))))
+      (list #:phases
+            #~(modify-phases %standard-phases
+                (add-after 'unpack 'patch
+                  (lambda _
+                    (substitute* "setup.py"
+                      (((string-append "'CC', " #$(cc-for-target)))
+                       ((string-append "'CC', " #$(cc-for-target))))))))))
     (native-inputs
-     `(("cython" ,python-cython)
-       ("gnupg" ,gnupg)
-       ("pkg-config" ,pkg-config)))
+      (list python-cython
+            gnupg
+            pkg-config))
     (propagated-inputs
      (list python-aiodns python-aiohttp python-pyasn1
            python-pyasn1-modules))