diff mbox series

[bug#54959,1/1] gnu: Add pikchr.

Message ID 20220415155332.17122-1-pukkamustard@posteo.net
State Accepted
Headers show
Series gnu: Add pikchr. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard April 15, 2022, 3:53 p.m. UTC
* gnu/packages/pikchr.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
 gnu/local.mk            |  1 +
 gnu/packages/pikchr.scm | 52 +++++++++++++++++++++++++++++++++++++++++
 2 files changed, 53 insertions(+)
 create mode 100644 gnu/packages/pikchr.scm

Comments

Ludovic Courtès April 20, 2022, 8:39 p.m. UTC | #1
Hi,

pukkamustard <pukkamustard@posteo.net> skribis:

> * gnu/packages/pikchr.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.

I tweaked the version number according to our guidelines (info "(guix)
Version Numbers"), wrapped the description as recommended by ‘guix
lint’, and committed the result.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 70133e6502..55ea4704c5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -474,6 +474,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/phabricator.scm 			\
   %D%/packages/php.scm				\
   %D%/packages/piet.scm			\
+  %D%/packages/pikchr.scm			\
   %D%/packages/pkg-config.scm			\
   %D%/packages/plan9.scm			\
   %D%/packages/plotutils.scm			\
diff --git a/gnu/packages/pikchr.scm b/gnu/packages/pikchr.scm
new file mode 100644
index 0000000000..7937ce6d56
--- /dev/null
+++ b/gnu/packages/pikchr.scm
@@ -0,0 +1,52 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 pukkamustard <pukkamustard@posteo.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages pikchr)
+  #:use-module (guix packages)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix download)
+  #:use-module ((guix licenses) #:prefix license:))
+
+(define-public pikchr
+  (package
+    (name "pikchr")
+    ;; To update, use the last check-in in https://pikchr.org/home/timeline?r=trunk
+    (version "221988914eff6efe")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://pikchr.org/home/tarball/" version
+                    "/pikchr.tar.gz"))
+              (sha256
+               (base32
+                "0yclkincsgfni4scjzp5avdsij8vmyxjn0q2qkwjhn3p43y8nxzd"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f ; no tests
+       #:phases (modify-phases %standard-phases
+                  (delete 'bootstrap)
+                  (delete 'configure)
+                  (replace 'install
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let* ((out (assoc-ref outputs "out"))
+                             (bin (string-append out "/bin")))
+                        (install-file "pikchr" bin)))))))
+    (home-page "https://pikchr.org")
+    (synopsis "A PIC-like markup language for diagrams in technical documentation")
+    (description "Pikchr (pronounced @dfn{picture}) is a PIC-like markup language for diagrams in technical documentation.  Pikchr is designed to be embedded in fenced code blocks of Markdown or similar mechanisms of other documentation markup languages.")
+    (license license:bsd-0)))