diff mbox series

[bug#54937] gnu: Add cl-numpy-file-format.

Message ID 20220414135037.32233-1-paul@apatience.com
State Accepted
Headers show
Series [bug#54937] gnu: Add cl-numpy-file-format. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 14, 2022, 1:50 p.m. UTC
* gnu/packages/lisp-xyz.scm (cl-numpy-file-format,
ecl-numpy-file-format, sbcl-numpy-file-format): New variables.
---
 gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

--
2.35.1

Comments

Guillaume Le Vaillant April 14, 2022, 2:35 p.m. UTC | #1
Patch pushed as 0ddca9d682013f10b7e0137878ab68363d929167.
Thanks.
Paul A. Patience April 14, 2022, 7:05 p.m. UTC | #2
On Thursday, April 14th, 2022 at 10:35, Guillaume Le Vaillant <glv@posteo.net> wrote:
> Patch pushed as 0ddca9d682013f10b7e0137878ab68363d929167.
> Thanks.

Should

    (file-name (git-file-name "cl-numpy-file-format" version))

not be

    (file-name (git-file-name "numpy-file-format" version))

instead?

Best regards,
Paul
Guillaume Le Vaillant April 14, 2022, 7:09 p.m. UTC | #3
"Paul A. Patience" <paul@apatience.com> skribis:

> On Thursday, April 14th, 2022 at 10:35, Guillaume Le Vaillant <glv@posteo.net> wrote:
>> Patch pushed as 0ddca9d682013f10b7e0137878ab68363d929167.
>> Thanks.
>
> Should
>
>     (file-name (git-file-name "cl-numpy-file-format" version))
>
> not be
>
>     (file-name (git-file-name "numpy-file-format" version))
>
> instead?
>
> Best regards,
> Paul

Previously, all CL packages using git-fetch were using
'(git-file-name name version)' in the 'source' field, and therefore the
sources were named "sbcl-something", which is a little weird as these
sources are also used for the "cl-*" and "ecl-*" packages that are
derived from the "sbcl-*" package definitions. The sources are not
specific to sbcl.
This is why when updating a CL package I use
'(git-file-name "cl-something" version)' instead. This way the naming
scheme for CL sources is similar to the others, like Python sources
fetched from git named "python-something", the R sources named
"r-something", etc.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 29b3a10d98..28b25edd24 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5151,6 +5151,38 @@  (define-public cl-find-port
 (define-public ecl-find-port
   (sbcl-package->ecl-package sbcl-find-port))

+(define-public sbcl-numpy-file-format
+  (let ((commit "e97aef6c592a412fdd1afa9a5f09d0b1ce134510")
+        (revision "1"))
+    (package
+      (name "sbcl-numpy-file-format")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/marcoheisig/numpy-file-format")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0j7jjcf6k3anvgpm4nf81g6gbhff44v0v9rai7kwm2bm3abzsjfd"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       (list sbcl-ieee-floats sbcl-trivial-features))
+      (home-page "https://github.com/marcoheisig/numpy-file-format")
+      (synopsis "Read and write NumPy .npy and .npz files")
+      (description
+       "The NUMPY-FILE-FORMAT library is a Common Lisp library for reading and
+writing NumPy @file{.npy} and @file{.npz} files.")
+      (license license:expat))))
+
+(define-public cl-numpy-file-format
+  (sbcl-package->cl-source-package sbcl-numpy-file-format))
+
+(define-public ecl-numpy-file-format
+  (sbcl-package->ecl-package sbcl-numpy-file-format))
+
 (define-public sbcl-py4cl
   (let ((commit "4c8a2b0814fd311f978964f825ce012290f60136")
         (revision "1"))