diff mbox series

[bug#54926] gnu: libfprint: Fix build, add python dependency for the tests.

Message ID 20220414081439.3686-1-attila@lendvai.name
State Accepted
Headers show
Series [bug#54926] gnu: libfprint: Fix build, add python dependency for the tests. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Attila Lendvai April 14, 2022, 8:14 a.m. UTC
* gnu/packages/freedesktop.scm (libfprint): Add python dependency to
native-inputs. Needed by the tests.
---
 gnu/packages/freedesktop.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Ricardo Wurmus April 14, 2022, 9:55 a.m. UTC | #1
Applied, thank you!

As discussed on IRC I changed “python” to “python-minimal”.
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 55bde8e705..f80c34a54e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1693,7 +1693,9 @@  (define-public libfprint
      (list `(,glib "bin")               ; for {glib-,}mkenums
            gobject-introspection
            gtk-doc/stable               ; for 88 KiB of API documentation
-           pkg-config))
+           pkg-config
+           ;; For tests
+           python))
     (inputs
      (list gusb
            libgudev