diff mbox series

[bug#54897] gnu: Add r-acde.

Message ID 20220412223047.9620-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#54897] gnu: Add r-acde. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu April 12, 2022, 10:30 p.m. UTC
* gnu/packages/bioconductor.scm (r-acde): New variable.
---
 gnu/packages/bioconductor.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Ricardo Wurmus April 14, 2022, 11:18 a.m. UTC | #1
Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 803437a033..87cbbb24fc 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -11642,6 +11642,31 @@  (define-public r-universalmotif
 motifs, and others.")
     (license license:gpl3)))
 
+(define-public r-acde
+  (package
+    (name "r-acde")
+    (version "1.24.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "acde" version))
+              (sha256
+               (base32
+                "13ks87am73m3bjn9ljapxml2a9cxdpgv9flwvly8aqmi3ndxyqi6"))))
+    (properties `((upstream-name . "acde")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-boot))
+    (home-page "https://bioconductor.org/packages/acde")
+    (synopsis
+     "Identification of differentially expressed genes with artificial components")
+    (description
+     "This package provides a multivariate inferential analysis method for
+detecting differentially expressed genes in gene expression data.  It uses
+artificial components, close to the data's principal components but with an
+exact interpretation in terms of differential genetic expression, to identify
+differentially expressed genes while controlling the @dfn{false discovery rate}
+(FDR).")
+    (license license:gpl3)))
+
 ;; This is a CRAN package, but it depends on Bioconductor packages, so we put
 ;; it here.
 (define-public r-activedriverwgs