diff mbox series

[bug#54875] gnu: sbcl-py4cl: Fix path to py4cl.py.

Message ID 20220412020807.35559-1-paul@apatience.com
State Accepted
Headers show
Series [bug#54875] gnu: sbcl-py4cl: Fix path to py4cl.py. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 12, 2022, 2:08 a.m. UTC
* gnu/packages/lisp-xyz.scm (sbcl-py4cl)[arguments]: Fix the path which
replaces py4cl/config:*base-directory*.
---

Hello,

This patch fixes the problem with sbcl-py4cl, but I suspect that the cl-py4cl
and ecl-py4cl packages were and remain broken, as the paths are different; for
example, cl-py4cl's py4cl.py is located in
/STORE-PATH/share/common-lisp/source/cl-py4cl/py4cl.py.
Unfortunately, I'm not sure how to address that in the package definition.

 gnu/packages/lisp-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--
2.35.1

Comments

Guillaume Le Vaillant April 12, 2022, 12:05 p.m. UTC | #1
Patch pushed as 1f22508a8a973a20cf33ba1d7f0869ada8258617, with the
hardcoded "sbcl" replaced by a call to the '%lisp-type' function which
should do the right thing.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 358bba4e89..b356c96f84 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5192,7 +5192,7 @@  (define-public sbcl-py4cl
                   (string-append
                    "\""
                    (assoc-ref outputs "out")
-                   "/share/common-lisp/sbcl-source/py4cl/"
+                   "/share/common-lisp/sbcl/py4cl/"
                    "\""))))))))
       (synopsis "Call python from Common Lisp")
       (description