diff mbox series

[bug#54853] gnu: orage: Update to 4.16.0.

Message ID 20220411135230.2861-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#54853] gnu: orage: Update to 4.16.0. | expand

Checks

Context Check Description
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder April 11, 2022, 1:52 p.m. UTC
* gnu/packages/xfce.scm (orage): Update to 4.16.0.
[arguments]: Remove unneeded phase fix-build-with-libical3.
[native-inputs]: Add glib:bin for dbus-binding-tool.
[inputs]: Add dbus-glib for dbus support, libxfce4ui.
---
 gnu/packages/xfce.scm | 19 +++++++------------
 1 file changed, 7 insertions(+), 12 deletions(-)

Comments

Ludovic Courtès April 18, 2022, 9:12 p.m. UTC | #1
Michael Rohleder <mike@rohleder.de> skribis:

> * gnu/packages/xfce.scm (orage): Update to 4.16.0.
> [arguments]: Remove unneeded phase fix-build-with-libical3.
> [native-inputs]: Add glib:bin for dbus-binding-tool.
> [inputs]: Add dbus-glib for dbus support, libxfce4ui.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 44b6c34b29..e89b1257bb 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1212,7 +1212,7 @@  (define-public xfce4-taskmanager
 (define-public orage
   (package
     (name "orage")
-    (version "4.12.1")
+    (version "4.16.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/apps/"
@@ -1220,20 +1220,15 @@  (define-public orage
                                   name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "0qlhvnl2m33vfxqlbkic2nmfpwyd4mq230jzhs48cg78392amy9w"))))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-build-with-libical3
-           (lambda* _
-             (substitute* "src/ical-code.c" ;; .is_utc not available in libical3
-               ((".*\\.is_utc.*$") ""))
-             #t)))))
+                "000py6r63rlv7pjwvwd7ycrb383lny8ha7ha3qpwh1r0d8xil496"))))
     (build-system gnu-build-system)
     (native-inputs
-     (list intltool pkg-config))
+     (list
+      `(,glib "bin")                    ; for dbus-binding-tool
+      intltool
+      pkg-config))
     (inputs
-     (list gtk+-2 libical libnotify popt xfce4-panel))
+     (list dbus-glib gtk+-2 libical libnotify libxfce4ui popt xfce4-panel))
     (home-page "https://www.xfce.org/projects/")
     (synopsis "Simple calendar application with reminders")
     (description