diff mbox series

[bug#54805,1/5] gnu: libadwaita: Update to 1.1.0.

Message ID 20220409005346.69279-1-alex@zrythm.org
State Accepted
Headers show
Series [bug#54805,1/5] gnu: libadwaita: Update to 1.1.0. | expand

Commit Message

Alexandros Theodotou April 9, 2022, 12:53 a.m. UTC
* gnu/packages/gnome.scm (libadwaita): Update to 1.1.0.
---
 gnu/packages/gnome.scm | 73 +++++++++++++++++++++---------------------
 1 file changed, 36 insertions(+), 37 deletions(-)

Comments

Ludovic Courtès June 14, 2022, 10:05 p.m. UTC | #1
Hi Alexandros,

Alexandros Theodotou <alex@zrythm.org> skribis:

> * gnu/packages/gnome.scm (libadwaita): Update to 1.1.0.

[...]

> * gnu/packages/audio.scm (rtmidi): Update to 5.0.0.

I finally pushed these two patches (apologies for the delay).  However,
I had to keep version 4.0 and use it for zrythm and milkytracker, which
would otherwise fail to build.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 19adb67423..ee59a90d91 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -70,6 +70,7 @@ 
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2022 Leo Nikkilä <hello@lnikki.la>
+;;; Copyright © 2022 Alexandros Theodotou <alex@zrythm.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -12684,45 +12685,43 @@  (define-public ocrfeeder
     (license license:gpl3+)))
 
 (define-public libadwaita
-  (let ((commit "8d66b987a19979d9d7b85dacc6bad5ce0c8743fe")
-        (revision "1"))
-    (package
-      (name "libadwaita")
-      (version (git-version "0.0.1" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://gitlab.gnome.org/GNOME/libadwaita.git")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0i3wav6jsyi4w4i2r1rad769m5y5s9djj4zqb7dfyh0bad24ba3q"))))
-      (build-system meson-build-system)
-      (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (add-before 'check 'pre-check
-             (lambda* (#:key inputs #:allow-other-keys)
-               ;; Tests require a running X server.
-               (system "Xvfb :1 &")
-               (setenv "DISPLAY" ":1"))))))
-      (native-inputs
-       `(("sassc" ,sassc)
-         ("glib:bin" ,glib "bin")
-         ("gtk-doc" ,gtk-doc/stable)
-         ("pkg-config" ,pkg-config)
-         ("vala" ,vala)
-         ("xvfb" ,xorg-server-for-tests)))
-      (inputs
-       (list gtk gobject-introspection libportal))
-      (home-page "https://gnome.pages.gitlab.gnome.org/libadwaita/")
-      (synopsis "Building blocks for GNOME applications")
-      (description
-       "@code{libadwaita} offers widgets and objects to build GNOME
+  (package
+    (name "libadwaita")
+    (version "1.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/libadwaita/"
+                                  (version-major+minor version) "/"
+                                  "libadwaita-" version ".tar.xz"))
+              (sha256
+               (base32
+                "03h14mrm453bn03f48rmpf85pvg5cnzzab27cs1c43417s09ixdg"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'pre-check
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; Tests require a running X server.
+             (system "Xvfb :1 &")
+             (setenv "DISPLAY" ":1"))))))
+    (native-inputs
+     `(("sassc" ,sassc)
+       ("glib:bin" ,glib "bin")
+       ("gtk-doc" ,gtk-doc/stable)
+       ("pkg-config" ,pkg-config)
+       ("vala" ,vala)
+       ("xvfb" ,xorg-server-for-tests)
+       ("gettext" ,gettext-minimal)))
+    (inputs
+     (list gtk gobject-introspection libportal))
+    (home-page "https://gnome.pages.gitlab.gnome.org/libadwaita/")
+    (synopsis "Building blocks for GNOME applications")
+    (description
+     "@code{libadwaita} offers widgets and objects to build GNOME
 applications scaling from desktop workstations to mobile phones.  It is the
 successor of @code{libhandy} for GTK4.")
-      (license license:lgpl2.1+))))
+    (license license:lgpl2.1+)))
 
 (define-public gnome-power-manager
   (package