diff mbox series

[bug#54801] gnu: lsof: Fix invalid G-Expression.

Message ID 20220408203034.oot2hkhnhurhjs7r@peregrine
State Accepted
Headers show
Series [bug#54801] gnu: lsof: Fix invalid G-Expression. | expand

Commit Message

Brian Kubisiak April 8, 2022, 8:30 p.m. UTC
Cross-compiling lsof is failing with an "invalid G-expression input"
error. Fix this by using a quoted list.

* gnu/packages/lsof.scm (lsof): Fix invalid G-Expression.
---
 gnu/packages/lsof.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ludovic Courtès April 8, 2022, 9:07 p.m. UTC | #1
Hi,

Brian Kubisiak <brian@kubisiak.com> skribis:

> Cross-compiling lsof is failing with an "invalid G-expression input"
> error. Fix this by using a quoted list.
>
> * gnu/packages/lsof.scm (lsof): Fix invalid G-Expression.

Good catch; applied.

>               ,@(if (%current-target-system)
> -                   (list (setenv "LINUX_CONF_CC" "gcc"))

Ouch, glad it wasn’t (delete-file-recursively "/").

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index be7bf43646..5f413483f4 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -55,7 +55,7 @@  (define-public lsof
            (lambda _
              (setenv "LSOF_CC" ,(cc-for-target))
              ,@(if (%current-target-system)
-                   (list (setenv "LINUX_CONF_CC" "gcc"))
+                   '((setenv "LINUX_CONF_CC" "gcc"))
                    '())
              (setenv "LSOF_MAKE" "make")