diff mbox series

[bug#53882,v2,23/25] gnu: Add ocaml-timezone.

Message ID 20220408132305.3301350-23-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#53882,v2,01/25] gnu: ocaml-odoc: Update to 2.2.0-alpha. | expand

Commit Message

Simon Tournier April 8, 2022, 1:23 p.m. UTC
From: Julien Lepiller <julien@lepiller.eu>

* gnu/packages/ocaml.scm (ocaml-timezone): New variable.
---
 gnu/packages/ocaml.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index be6477edbe..c1e30ba88f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6976,6 +6976,28 @@  (define-public ocaml4.07-core-kernel
                  ;; MLton and sjs
                  license:expat)))))
 
+(define-public ocaml-timezone
+  (package
+    (name "ocaml-timezone")
+    (version "0.14.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/janestreet/timezone")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "0zf075k94nk2wxnzpxia7pnm655damwp1b58xf2s9disia1ydxg7"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-core-kernel ocaml-ppx-jane))
+    (home-page "https://github.com/janestreet/timezone")
+    (synopsis "Time-zone handling")
+    (description
+      "Timezone handles parsing timezone data and create @code{Timezone.t}
+that can later be used to manipulate time in core_kernel or core.")
+    (license license:expat)))
+
 (define-public ocaml-markup
   (package
     (name "ocaml-markup")