diff mbox series

[bug#54771] gnu: Add emacs-hledger-mode

Message ID 20220407165442.23653-1-collin@rekahsoft.ca
State New
Headers show
Series [bug#54771] gnu: Add emacs-hledger-mode | expand

Commit Message

Collin J. Doering April 7, 2022, 4:54 p.m. UTC
* gnu/packages/finance.scm (emacs-hledger-mode): New variable
---
 gnu/packages/finance.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Collin J. Doering April 8, 2022, 1:30 a.m. UTC | #1
For some reason I haven't seen this issue appear on Guix's Mumi instance (https://issues.guix.gnu.org), however it appears that it was successfully received.

Sending this email as I suspect it will make this bug ticket show up in mumi.
Simon Tournier April 8, 2022, 7:52 a.m. UTC | #2
Hi,

On Fri, 8 Apr 2022 at 03:33, Collin J. Doering via Guix-patches via
<guix-patches@gnu.org> wrote:

> For some reason I haven't seen this issue appear on Guix's Mumi instance (https://issues.guix.gnu.org), however it appears that it was successfully received.

The synchronisation of the instance Mumi can vary.  It is probably
what you observed.

Cheers,
simon
Collin J. Doering March 18, 2023, 12:53 a.m. UTC | #3
This was already merged (see: https://git.savannah.gnu.org/cgit/guix.git/commit/gnu?id=3650425b4689ff716ad244cb48283c9daf8df148)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 9f2d055048..d6cd2981a6 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -73,6 +73,7 @@  (define-module (gnu packages finance)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages dns)
   #:use-module (gnu packages emacs)
+  #:use-module (gnu packages emacs-xyz)
   #:use-module (gnu packages dbm)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gnome)
@@ -455,6 +456,37 @@  (define-public emacs-ledger-mode
 This package provides the Emacs mode.")
     (license license:gpl2+)))
 
+(define-public emacs-hledger-mode
+  (let ((commit "9ac07ff0adbce6a402c17e789b1750f9da0d22f4")
+        (revision "1"))
+    (package
+      (name "emacs-hledger-mode")
+      (version (git-version "20210706.1225" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/narendraj9/hledger-mode")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "0x3dgws8nh7q8x7zzjwbm5k9n7gi7qqd3ww7y51fbx6p6ii3jpp4"))))
+      (build-system emacs-build-system)
+      (propagated-inputs `(("emacs-popup" ,emacs-popup)
+                           ("emacs-async" ,emacs-async)
+                           ("emacs-htmlize" ,emacs-htmlize)))
+      (arguments
+       '(#:include '("^[^/]+.el$")
+         #:exclude '()))
+      (home-page "https://github.com/narendraj9/hledger-mode")
+      (synopsis "Mode for writing journal entries for hledger")
+      (description
+       "A major mode for writing hledger journal files.  It generates some
+useful reports along with some financial ratios that can help you
+keep a check on your financial health.  This is an attempt to
+organize personal finances for Emacs users.  If you don not like this,
+try @code{emacs-ledger-mode}.")
+      (license license:gpl3))))
+
 (define-public geierlein
   (package
     (name "geierlein")