diff mbox series

[bug#54678,v2] gnu: Add emacs-pyimport.

Message ID 20220405204839.19146-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54678,v2] gnu: Add emacs-pyimport. | expand

Commit Message

jgart April 5, 2022, 8:48 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-pyimport): New variable.

Hi Maxime,

Here's a v2 with your suggestions.

Thanks for the code review.

all best,

jgart

---
 gnu/packages/emacs-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

Comments

M May 9, 2022, 5:49 p.m. UTC | #1
jgart schreef op di 05-04-2022 om 16:48 [-0400]:
> +      (license license:gpl3+)))) ; License is in pyimport.el

The license header is present, but the actual license text is missing,
and the GPL requires:

> and give all recipients a copy of this License along with the Program.

Looks like upstream forgot a file ...

Greetings,
Maxime.
Nicolas Goaziou June 7, 2022, 10:15 p.m. UTC | #2
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-pyimport): New variable.

Applied. Thank you.

Regards,
M June 8, 2022, 7:52 a.m. UTC | #3
reopen 54678
thanks

Nicolas Goaziou schreef op wo 08-06-2022 om 00:15 [+0200]:
> jgart via Guix-patches via <guix-patches@gnu.org> writes:
> 
> > * gnu/packages/emacs-xyz.scm (emacs-pyimport): New variable.
> 
> Applied. Thank you.

What about <https://issues.guix.gnu.org/54678#3>?

Greetings,
Maxime.
Nicolas Goaziou June 10, 2022, 9:08 a.m. UTC | #4
Hello,

Maxime Devos <maximedevos@telenet.be> writes:

> reopen 54678
> thanks
>
> Nicolas Goaziou schreef op wo 08-06-2022 om 00:15 [+0200]:
>> jgart via Guix-patches via <guix-patches@gnu.org> writes:
>> 
>> > * gnu/packages/emacs-xyz.scm (emacs-pyimport): New variable.
>> 
>> Applied. Thank you.
>
> What about <https://issues.guix.gnu.org/54678#3>?

I asked a similar question for a different package some months (years?)
ago. The decision was that we should assume good faith from the author,
even if the licensing is not perfect. In this situation, upstream intent
is clear, so there is no real issue.

Of course, it would be nice to help upstream have a correct licensing
process.

Regards,
M June 10, 2022, 3:05 p.m. UTC | #5
Nicolas Goaziou schreef op vr 10-06-2022 om 11:08 [+0200]:
> [...]
> I asked a similar question for a different package some months (years?)
> ago. The decision was that we should assume good faith from the author,
> even if the licensing is not perfect. In this situation, upstream intent
> is clear, so there is no real issue.
> 
> Of course, it would be nice to help upstream have a correct licensing
> process.
> 
> Regards,

Thanks for your answer, I'll keep it in mind.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bc9a9f1c28..dcd1f07916 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30828,6 +30828,43 @@  (define-public emacs-org-modern
 headlines, keywords, tables and source blocks.")
    (license license:gpl3+)))
 
+(define-public emacs-pyimport
+  (let ((commit "a6f63cf7ed93f0c0f7c207e6595813966f8852b9")
+        (revision "0"))
+    (package
+      (name "emacs-pyimport")
+      (version (git-version "1.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/Wilfred/pyimport")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1q5gqhvh4zq5dy8vns694warcz48j1hdnxg16sjck4gsi9xivbvs"))))
+      (build-system emacs-build-system)
+      (inputs
+        (list python-pyflakes))
+      (propagated-inputs
+        (list emacs-dash emacs-s emacs-shut-up))
+      (arguments
+        (list #:phases
+              #~(modify-phases %standard-phases
+                  (add-after 'unpack 'patch-pyflakes-executable
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (let ((pyflakes (search-input-file inputs "/bin/pyflakes")))
+                        (make-file-writable "pyimport.el")
+                        (substitute* "pyimport.el"
+                          (("\"pyflakes")
+                           (string-append "\"" pyflakes)))))))))
+      (home-page "https://github.com/Wilfred/pyimport")
+      (synopsis "Manage Python imports from Emacs")
+      (description
+"@code{emacs-pyimport} manages python imports from Emacs via @code{python-pyflakes}.")
+      (license license:gpl3+)))) ; License is in pyimport.el
+
 (define-public emacs-osm
   (package
     (name "emacs-osm")