diff mbox series

[bug#54738] gnu: Add emacs-toodoo.

Message ID 20220405203516.84365-1-stefan@xsteve.at
State Accepted
Headers show
Series [bug#54738] gnu: Add emacs-toodoo. | expand

Commit Message

Stefan Reichör April 5, 2022, 8:35 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-toodoo): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 +++++++++++++++++++++++++++-
 1 file changed, 27 insertions(+), 1 deletion(-)

Comments

Nicolas Goaziou June 7, 2022, 10:10 p.m. UTC | #1
Hello,

Stefan Reichör <stefan@xsteve.at> writes:

> * gnu/packages/emacs-xyz.scm (emacs-toodoo): New variable.

Pushed with the change below.

Thanks.

> +(define-public emacs-toodoo
> +  ;; Package has no release.  Version is extracted from "Version:" keyword in
> +  ;; main file.
> +  (let ((commit "149a563863c2f728c5f903475dbce50547c51000")
> +        (revision "0"))
> +    (package
> +      (name "emacs-toodoo")
> +      (version (git-version "0.2" revision commit))

I made it version "0.2" since the commit you provide matches the version
bump.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ffa45e218a..fd7226aa58 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -94,7 +94,7 @@ 
 ;;; Copyright © 2021 Yurii Kholodkov <urist.mckorobochka@gmail.com>
 ;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
-;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021, 2022 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2021 Eugene Klimov <lipklim@mailbox.org>
 ;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
@@ -12792,6 +12792,32 @@  properties are set on a heading, and when it is changing from a TODO state to
 a DONE state.")
     (license license:gpl3+)))
 
+(define-public emacs-toodoo
+  ;; Package has no release.  Version is extracted from "Version:" keyword in
+  ;; main file.
+  (let ((commit "149a563863c2f728c5f903475dbce50547c51000")
+        (revision "0"))
+    (package
+      (name "emacs-toodoo")
+      (version (git-version "0.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/ChanderG/toodoo.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "00q7aym0kl03j9m66pivgy0snxcjjg402049b2wdy18kgyypfvx8"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-transient emacs-evil))
+      (home-page "https://github.com/ChanderG/toodoo.el")
+      (synopsis "Magit like interface for a simple Todo workflow built on top of Org")
+      (description "Provides a minor mode for fast and easy management
+of Todos using Org-mode and transients.")
+    (license license:asl2.0))))
+
 (define-public emacs-flx
   (package
     (name "emacs-flx")