diff mbox series

[bug#54703,3/3] gnu: wpewebkit: Update to 2.36.0.

Message ID 20220404041743.11131-3-maxim.cournoyer@gmail.com
State Accepted
Headers show
Series Update webkitgtk to 2.36.0 and enable new features. | expand

Commit Message

Maxim Cournoyer April 4, 2022, 4:17 a.m. UTC
* gnu/packages/webkit.scm (wpewebkit): Update to 2.36.0, rewriting package to
inherit from webkitgtk.
---
 gnu/packages/webkit.scm | 126 ++++------------------------------------
 1 file changed, 11 insertions(+), 115 deletions(-)

Comments

Liliana Marie Prikler April 4, 2022, 6:14 a.m. UTC | #1
Am Montag, dem 04.04.2022 um 00:17 -0400 schrieb Maxim Cournoyer:
> * gnu/packages/webkit.scm (wpewebkit): Update to 2.36.0, rewriting
> package to
> inherit from webkitgtk.
> ---
>  gnu/packages/webkit.scm | 126 ++++----------------------------------
> --
>  1 file changed, 11 insertions(+), 115 deletions(-)
> 
> diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
> index cd19404228..bc3ae388f7 100644
> --- a/gnu/packages/webkit.scm
> +++ b/gnu/packages/webkit.scm
> @@ -123,121 +123,6 @@ (define-public wpebackend-fdo
>  engine that uses Wayland for graphics output.")
>      (license license:bsd-2)))
>  
> -(define-public wpewebkit
> -  (package
> -    (name "wpewebkit")
> -    (version "2.34.3")
> -    (source
> -     (origin
> -       (method url-fetch)
> -       (uri
> -        (string-append "https://wpewebkit.org/releases/"
> -                       name "-" version ".tar.xz"))
> -       (sha256
> -        (base32
> "1z20bza01ld4jvi0qx8xsl5y4czaniwpi8hxdjyirj1mrszy8pf3"))))
> -    (build-system cmake-build-system)
> -    (outputs '("out" "doc"))
> -    (arguments
> -     `(#:tests? #f                      ; XXX: To be enabled
> -       #:configure-flags
> -       (list
> -        "-DPORT=WPE"
> -        ;; XXX: To be enabled.
> -        ;; "-DENABLE_ACCELERATED_2D_CANVAS=ON"
> -        "-DUSE_SYSTEMD=OFF"
> -        "-DENABLE_ENCRYPTED_MEDIA=OFF"
> -        "-DENABLE_GTKDOC=ON"
> -        "-DUSE_GSTREAMER_GL=OFF")
> -       #:phases
> -       (modify-phases %standard-phases
> -         (add-after 'unpack 'setenv
> -           (lambda _
> -             (setenv "HOME" "/tmp")
> -             #t))
> -         (add-after 'unpack 'patch-docbook-xml
> -           (lambda* (#:key inputs #:allow-other-keys)
> -             (for-each
> -              (lambda (file)
> -                (substitute* file
> -                 
> (("http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd")
> -                   (string-append (assoc-ref inputs "docbook-xml")
> -                                 
> "/xml/dtd/docbook/docbookx.dtd"))))
> -              (find-files "Source" "\\.sgml$"))
> -             #t))
> -         (add-after 'unpack 'patch-cmake
> -           (lambda _
> -             (substitute* "Source/PlatformWPE.cmake"
> -               (("(Documentation/wpe(-webextensions)?-
> )\\$\\{WPE_API_VERSION\\}"
> -                 all prefix)
> -                (string-append prefix "${WPE_API_DOC_VERSION}"))
> -               (("(html/wpe(-webextensions)?-
> )\\$\\{WPE_API_VERSION\\}"
> -                 all prefix)
> -                (string-append prefix "${WPE_API_DOC_VERSION}")))))
> -         (add-after 'install 'move-doc-files
> -           (lambda* (#:key outputs #:allow-other-keys)
> -             (let* ((out (assoc-ref outputs "out"))
> -                    (doc (assoc-ref outputs "doc")))
> -               (mkdir-p (string-append doc "/share"))
> -               (rename-file
> -                (string-append out "/share/gtk-doc")
> -                (string-append doc "/share/gtk-doc"))
> -               #t))))))
> -    (native-inputs
> -     `(("docbook-xml" ,docbook-xml-4.1.2)
> -       ("docbook-xsl" ,docbook-xsl)
> -       ("glib:bin" ,glib "bin")
> -       ("gobject-introspection" ,gobject-introspection)
> -       ("gtk-doc" ,gtk-doc/stable)
> -       ("perl" ,perl)
> -       ("pkg-config" ,pkg-config)
> -       ("python" ,python-wrapper)
> -       ("python2" ,python-2.7)
> -       ("ruby" ,ruby)))
> -    (inputs
> -     `(("atk" ,atk)
> -       ("atk-bridge" ,at-spi2-atk)
> -       ("bubblewrap" ,bubblewrap)
> -       ("cairo" ,cairo)
> -       ("fontconfig" ,fontconfig)
> -       ("freetype" ,freetype)
> -       ("gperf" ,gperf)
> -       ("gstreamer" ,gstreamer)
> -       ("gst-plugins-base" ,gst-plugins-base)
> -       ("harfbuzz" ,harfbuzz)
> -       ("icu" ,icu4c)
> -       ("lcms" ,lcms)
> -       ("libepoxy" ,libepoxy)
> -       ("libgcrypt" ,libgcrypt)
> -       ("libjpeg" ,libjpeg-turbo)
> -       ("libpng" ,libpng)
> -       ("libseccomp" ,libseccomp)
> -       ("libtasn1" ,libtasn1)
> -       ("libxml2" ,libxml2)
> -       ("libxslt" ,libxslt)
> -       ("mesa" ,mesa)
> -       ("openjpeg" ,openjpeg)
> -       ("sqlite" ,sqlite)
> -       ("webp" ,libwebp)
> -       ("woff2" ,woff2)
> -       ("xdg-dbus-proxy" ,xdg-dbus-proxy)
> -       ("zlib" ,zlib)))
> -    (propagated-inputs
> -     `(("glib" ,glib)
> -       ("libsoup" ,libsoup)
> -       ("wpe" ,libwpe)))
> -    (synopsis "WebKit port optimized for embedded devices")
> -    (description "WPE WebKit allows embedders to create simple and
> performant
> -systems based on Web platform technologies.  It is designed with
> hardware
> -acceleration in mind, leveraging common 3D graphics APIs for best
> performance.")
> -    (home-page "https://wpewebkit.org/")
> -    (license
> -     (list
> -      ;; Rendering and JavaScript Engines.
> -      license:lgpl2.1+
> -      ;; Others
> -      license:bsd-2))
> -    (properties '((cpe-name . "wpe_webkit")))))
> -
>  (define-public webkitgtk
>    (package
>      (name "webkitgtk")
> @@ -398,3 +283,14 @@ (define-public webkitgtk-with-libsoup2
>      (propagated-inputs
>       (modify-inputs (package-propagated-inputs webkitgtk)
>         (replace "libsoup" libsoup-minimal-2)))))
> +
> +(define-public wpewebkit
> +  (package
> +    (inherit webkitgtk)
> +    (name "wpewebkit")
> +    (synopsis "WebKit port optimized for embedded devices")
> +    (description "WPE WebKit allows embedders to create simple and
> performant
> +systems based on Web platform technologies.  It is designed with
> hardware
> +acceleration in mind, leveraging common 3D graphics APIs for best
> performance.")
> +    (home-page "https://wpewebkit.org/")
> +    (properties '((cpe-name . "wpe_webkit")))))
You're not packaging WPEWebkit here, you are packaging WebkitGTK and
labelling it WPEWebkit.
Maxim Cournoyer April 5, 2022, 12:26 a.m. UTC | #2
Hello,

Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> writes:

> Am Montag, dem 04.04.2022 um 00:17 -0400 schrieb Maxim Cournoyer:
>> * gnu/packages/webkit.scm (wpewebkit): Update to 2.36.0, rewriting
>> package to
>> inherit from webkitgtk.

[...]

>> +(define-public wpewebkit
>> +  (package
>> +    (inherit webkitgtk)
>> +    (name "wpewebkit")
>> +    (synopsis "WebKit port optimized for embedded devices")
>> +    (description "WPE WebKit allows embedders to create simple and
>> performant
>> +systems based on Web platform technologies.  It is designed with
>> hardware
>> +acceleration in mind, leveraging common 3D graphics APIs for best
>> performance.")
>> +    (home-page "https://wpewebkit.org/")
>> +    (properties '((cpe-name . "wpe_webkit")))))

> You're not packaging WPEWebkit here, you are packaging WebkitGTK and
> labelling it WPEWebkit.

Hmm, indeed :-) Thanks for catching that.  A v2 will follow.

Thank you!

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index cd19404228..bc3ae388f7 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -123,121 +123,6 @@  (define-public wpebackend-fdo
 engine that uses Wayland for graphics output.")
     (license license:bsd-2)))
 
-(define-public wpewebkit
-  (package
-    (name "wpewebkit")
-    (version "2.34.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri
-        (string-append "https://wpewebkit.org/releases/"
-                       name "-" version ".tar.xz"))
-       (sha256
-        (base32 "1z20bza01ld4jvi0qx8xsl5y4czaniwpi8hxdjyirj1mrszy8pf3"))))
-    (build-system cmake-build-system)
-    (outputs '("out" "doc"))
-    (arguments
-     `(#:tests? #f                      ; XXX: To be enabled
-       #:configure-flags
-       (list
-        "-DPORT=WPE"
-        ;; XXX: To be enabled.
-        ;; "-DENABLE_ACCELERATED_2D_CANVAS=ON"
-        "-DUSE_SYSTEMD=OFF"
-        "-DENABLE_ENCRYPTED_MEDIA=OFF"
-        "-DENABLE_GTKDOC=ON"
-        "-DUSE_GSTREAMER_GL=OFF")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'setenv
-           (lambda _
-             (setenv "HOME" "/tmp")
-             #t))
-         (add-after 'unpack 'patch-docbook-xml
-           (lambda* (#:key inputs #:allow-other-keys)
-             (for-each
-              (lambda (file)
-                (substitute* file
-                  (("http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd")
-                   (string-append (assoc-ref inputs "docbook-xml")
-                                  "/xml/dtd/docbook/docbookx.dtd"))))
-              (find-files "Source" "\\.sgml$"))
-             #t))
-         (add-after 'unpack 'patch-cmake
-           (lambda _
-             (substitute* "Source/PlatformWPE.cmake"
-               (("(Documentation/wpe(-webextensions)?-)\\$\\{WPE_API_VERSION\\}"
-                 all prefix)
-                (string-append prefix "${WPE_API_DOC_VERSION}"))
-               (("(html/wpe(-webextensions)?-)\\$\\{WPE_API_VERSION\\}"
-                 all prefix)
-                (string-append prefix "${WPE_API_DOC_VERSION}")))))
-         (add-after 'install 'move-doc-files
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (doc (assoc-ref outputs "doc")))
-               (mkdir-p (string-append doc "/share"))
-               (rename-file
-                (string-append out "/share/gtk-doc")
-                (string-append doc "/share/gtk-doc"))
-               #t))))))
-    (native-inputs
-     `(("docbook-xml" ,docbook-xml-4.1.2)
-       ("docbook-xsl" ,docbook-xsl)
-       ("glib:bin" ,glib "bin")
-       ("gobject-introspection" ,gobject-introspection)
-       ("gtk-doc" ,gtk-doc/stable)
-       ("perl" ,perl)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python-wrapper)
-       ("python2" ,python-2.7)
-       ("ruby" ,ruby)))
-    (inputs
-     `(("atk" ,atk)
-       ("atk-bridge" ,at-spi2-atk)
-       ("bubblewrap" ,bubblewrap)
-       ("cairo" ,cairo)
-       ("fontconfig" ,fontconfig)
-       ("freetype" ,freetype)
-       ("gperf" ,gperf)
-       ("gstreamer" ,gstreamer)
-       ("gst-plugins-base" ,gst-plugins-base)
-       ("harfbuzz" ,harfbuzz)
-       ("icu" ,icu4c)
-       ("lcms" ,lcms)
-       ("libepoxy" ,libepoxy)
-       ("libgcrypt" ,libgcrypt)
-       ("libjpeg" ,libjpeg-turbo)
-       ("libpng" ,libpng)
-       ("libseccomp" ,libseccomp)
-       ("libtasn1" ,libtasn1)
-       ("libxml2" ,libxml2)
-       ("libxslt" ,libxslt)
-       ("mesa" ,mesa)
-       ("openjpeg" ,openjpeg)
-       ("sqlite" ,sqlite)
-       ("webp" ,libwebp)
-       ("woff2" ,woff2)
-       ("xdg-dbus-proxy" ,xdg-dbus-proxy)
-       ("zlib" ,zlib)))
-    (propagated-inputs
-     `(("glib" ,glib)
-       ("libsoup" ,libsoup)
-       ("wpe" ,libwpe)))
-    (synopsis "WebKit port optimized for embedded devices")
-    (description "WPE WebKit allows embedders to create simple and performant
-systems based on Web platform technologies.  It is designed with hardware
-acceleration in mind, leveraging common 3D graphics APIs for best performance.")
-    (home-page "https://wpewebkit.org/")
-    (license
-     (list
-      ;; Rendering and JavaScript Engines.
-      license:lgpl2.1+
-      ;; Others
-      license:bsd-2))
-    (properties '((cpe-name . "wpe_webkit")))))
-
 (define-public webkitgtk
   (package
     (name "webkitgtk")
@@ -398,3 +283,14 @@  (define-public webkitgtk-with-libsoup2
     (propagated-inputs
      (modify-inputs (package-propagated-inputs webkitgtk)
        (replace "libsoup" libsoup-minimal-2)))))
+
+(define-public wpewebkit
+  (package
+    (inherit webkitgtk)
+    (name "wpewebkit")
+    (synopsis "WebKit port optimized for embedded devices")
+    (description "WPE WebKit allows embedders to create simple and performant
+systems based on Web platform technologies.  It is designed with hardware
+acceleration in mind, leveraging common 3D graphics APIs for best performance.")
+    (home-page "https://wpewebkit.org/")
+    (properties '((cpe-name . "wpe_webkit")))))