[bug#54692] gnu: Add emacs-opencl-mode
Commit Message
Hello Maxime,
thank you for your feedback. Here I send a new patch with the suggested
corrections.
About your questions:
- cc-fonts is part of emacs
- Offline access to the OpenCL documentation would indeed be nice, I guess
this should however be a separate package. I could add this afterwards,
once this package is available.
Greetings,
Thomas
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Comments
Thomas Albers schreef op zo 03-04-2022 om 19:53 [+0200]:
> + (description "This Emacs package provides the @code{opencl-mode} major
> +mode for editing OpenCL kernels. It supports syntax highlighting and online
> +access to the OpenCL documentation through the @code{opencl-lookup} function.")
Looks like a nice description!
Greetings,
Maxime.
Hello,
Thomas Albers via Guix-patches via <guix-patches@gnu.org> writes:
>
> ---
> gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 42fc13f4c2..8aef0b42eb 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -108,6 +108,7 @@
> ;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
> ;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
> ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
> +;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -30833,3 +30834,27 @@ (define-public emacs-osm
> zoomable and moveable map display, display of tracks and POIs from GPX files,
> parallel fetching of tiles with cURL, and more.")
> (license license:gpl3+)))
> +
> +(define-public emacs-opencl-mode
I added a proper commit message and pushed.
Thank you.
Regards,
@@ -108,6 +108,7 @@
;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30833,3 +30834,27 @@ (define-public emacs-osm
zoomable and moveable map display, display of tracks and POIs from GPX files,
parallel fetching of tiles with cURL, and more.")
(license license:gpl3+)))
+
+(define-public emacs-opencl-mode
+ ;; Upstream never makes any formal releases, there is only v1.0.
+ ;; Use the latest commit instead.
+ (let ((commit "15091eff92c33ee0d1ece40eb99299ef79fee92d")
+ (revision "1"))
+ (package
+ (name "emacs-opencl-mode")
+ (version (git-version "1.0" revision commit))
+ (source (origin
+ (uri (git-reference
+ (url "https://github.com/salmanebah/opencl-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zn6rr48w0ai0sn51zzyp546va6flfgf9lm12vfrdb6kkiiiq403"))
+ (method git-fetch)))
+ (build-system emacs-build-system)
+ (synopsis "Emacs major mode for editing OpenCL kernels")
+ (description "This Emacs package provides the @code{opencl-mode} major
+mode for editing OpenCL kernels. It supports syntax highlighting and online
+access to the OpenCL documentation through the @code{opencl-lookup} function.")
+ (home-page "https://github.com/salmanebah/opencl-mode")
+ (license license:gpl3+))))