diff mbox series

[bug#54693] gnu: pantheon-calculator: Update to 1.7.2.

Message ID 20220403155412.16136-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#54693] gnu: pantheon-calculator: Update to 1.7.2. | expand

Commit Message

jgart April 3, 2022, 3:54 p.m. UTC
* gnu/packages/pantheon.scm (pantheon-calculator): Update to 1.7.2.
[arguments]: Remove trailing boolean.
[inputs]: Use guix style and add libhandy input.
---
 gnu/packages/pantheon.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

Comments

Ludovic Courtès April 5, 2022, 6:28 p.m. UTC | #1
jgart <jgart@dismail.de> skribis:

> * gnu/packages/pantheon.scm (pantheon-calculator): Update to 1.7.2.
> [arguments]: Remove trailing boolean.
> [inputs]: Use guix style and add libhandy input.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 756db94144..acb19a3ef8 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -67,7 +67,7 @@  (define-public granite
 (define-public pantheon-calculator
   (package
     (name "pantheon-calculator")
-    (version "1.5.5")
+    (version "1.7.2")
     (source
      (origin
        (method git-fetch)
@@ -77,7 +77,7 @@  (define-public pantheon-calculator
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1csxsr2c8qvl97xz9ahwn91z095nzgr0i1mbcb1spljll2sr9lkj"))))
+         "11rwwi6nlhwpcm29dn2mbz0239nfjdwlqlqbchm0j9sr1ypifk2k"))))
     (build-system meson-build-system)
     (arguments
      `(#:glib-or-gtk? #t
@@ -85,13 +85,13 @@  (define-public pantheon-calculator
        (modify-phases %standard-phases
          (add-after 'unpack 'disable-schema-cache-generation
            (lambda _
-             (setenv "DESTDIR" "/")
-             #t)))))
+             (setenv "DESTDIR" "/"))))))
     (inputs
-     `(("granite" ,granite)
-       ("glib" ,glib)
-       ("gtk" ,gtk+)
-       ("libgee" ,libgee)))
+      (list granite
+            glib
+            gtk+
+            libgee
+            libhandy))
     (native-inputs
      `(("cmake" ,cmake)
        ("glib:bin" ,glib "bin") ; for glib-compile-schemas