diff mbox series

[bug#54692] gnu: Add emacs-opencl-mode

Message ID 20220403134116.7688-1-thomas@thomaslabs.org
State Accepted
Headers show
Series [bug#54692] gnu: Add emacs-opencl-mode | expand

Commit Message

Thomas Albers Raviola April 3, 2022, 1:41 p.m. UTC
Hi guix,

the following patch adds the emacs-opencl-mode package. It provides
syntax highlighting when editing OpenCL kernels.

Regards,
Thomas

---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

--
2.34.0

Comments

M April 3, 2022, 2:30 p.m. UTC | #1
Thomas Albers via Guix-patches via schreef op zo 03-04-2022 om 15:41
[+0200]:
> +      (license license:gpl3))))

According to opencl-mode.el, it's GPL3+.

Greetings,
Maxime.
M April 3, 2022, 2:31 p.m. UTC | #2
Thomas Albers via Guix-patches via schreef op zo 03-04-2022 om 15:41
[+0200]:
> +      (source (origin

The code does (require 'cc-fonts) -- is this part of Emacs itself, or
is it a dependency that needs to be added to propagated-inputs?

Greetings,
Maxime.
M April 3, 2022, 2:33 p.m. UTC | #3
Thomas Albers via Guix-patches via schreef op zo 03-04-2022 om 15:41
[+0200]:
> +      (version (git-version "1.0" revision commit))

I would add a comment here, maybe

   ;; Upstream never makes any formal releases, there is only v1.0.
   ;; Use the latest commit instead.

to explain why a non-version commit was chosen.

Greetings,
Maxime.
M April 3, 2022, 2:42 p.m. UTC | #4
Thomas Albers via Guix-patches via schreef op zo 03-04-2022 om 15:41
[+0200]:
> +      (description "This Emacs package provides syntax coloring for OpenCL kernels.")

This is a bit short.  Some additional things that could be mentioned:


  * the name of the emacs mode (in case a non-recognised file name is
    used)
  * its documentation support (opencl-lookup)

Additionally, for offline usage, it would be nice if the OpenCL
documentation was built from source (*) and referred to by
file:///gnu/store/... instead of http://www.khronos.org, though I don't
think that can be a requirement.

Greetings,
Maxime.

(*) https://github.com/KhronosGroup/OpenCL-Docs#license
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 42fc13f4c2..6c82a9d784 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -108,6 +108,7 @@ 
 ;;; Copyright © 2021, 2022 Taiju HIGASHI <higashi@taiju.info>
 ;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -30833,3 +30834,23 @@  (define-public emacs-osm
 zoomable and moveable map display, display of tracks and POIs from GPX files,
 parallel fetching of tiles with cURL, and more.")
     (license license:gpl3+)))
+
+(define-public emacs-opencl-mode
+  (let ((commit "15091eff92c33ee0d1ece40eb99299ef79fee92d")
+        (revision "1"))
+    (package
+      (name "emacs-opencl-mode")
+      (version (git-version "1.0" revision commit))
+      (source (origin
+                (uri (git-reference
+                      (url "https://github.com/salmanebah/opencl-mode")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32 "1zn6rr48w0ai0sn51zzyp546va6flfgf9lm12vfrdb6kkiiiq403"))
+                (method git-fetch)))
+      (build-system emacs-build-system)
+      (synopsis "OpenCL syntax coloring for Emacs")
+      (description "This Emacs package provides syntax coloring for OpenCL kernels.")
+      (home-page "https://github.com/salmanebah/opencl-mode")
+      (license license:gpl3))))